Advantages of running a cardano-node

I’m trying to setup a cardano-node on a VPS believing it will enable me to do some stacking. Is that correct ?

And what other advantages is there to run a cardano-node on a VPS?

If you just want to stake you don’t need to run a node, just delegate to an existing pool. Running a pool just for your own stake will not be cost effective unless you are a whale. Also, if you do want to run a pool, please be aware, there’s quite a lot to learn!

I’m willing to take time to learn what it takes. It’s only the beginning isn’t it?
And I have been watching crypto space since 2011. I have some background already, although not in Haskell.
I appreciate your warning. it reminds me of the one I give to people wanting to learn emacs. :o)

So I understand that the advantage of running a pool is that you can host other peoples stakes and therefore set the rule for sharing the reward. OK.
Your reply refreshed my mind.

Thank you

1 Like

yes! it is only the beginning. go for it dude, learn what it takes, don’t be swayed by off-putting nay-sayers!

here’s a great place to start!

1 Like

My cardano-node test launch

The hard way

@misteraxyz I appreciate your encouragement, but you are pointing the hard way for me. I found your link earlier but I was looking for a more comprehensive way, one more suited for someone who does not like one finger clicking device and virtual box stuff, too much.

The following 2 links helped me quite a lot:

The easy way: a resume of my journey with no pointing device

Environment

A distant Virtual Private Server (VPS) with Debian 10 (buster)

Preparation (updating stuff)

sudo apt-get update -y
sudo apt-get -y install build-essential pkg-config libffi-dev libgmp-dev libssl-dev libtinfo-dev libsystemd-dev zlib1g-dev make g++ tmux git jq wget libncursesw5 -y

Install Haskell stuff

Cabal

This was kind of new to me. I never touched Haskell stuff before. It did not always go smoothly and I had to go back and forth a few times to the Haskell Cabal overview . Butthe the following worked

apt-get install cabal-install
cabal update
cabal install Cabal cabal-install 

Latest ghc version

I’m not sure why I ended up installing this Glorious Glasgow Haskell Compiler. It’s probably because latter steps require it, but I can’t say which. Any how, I adapted the code from the last snippet of https://crypto.bi/tape/cardano-node/. I checked the latest ghc for Debian 10, downloaded and configure.

wget https://downloads.haskell.org/~ghc/latest/ghc-<latest-os-version>-linux.tar.xz
tar -xf ghc-<latest-os-version>-linux.tar.xz
rm ghc-<latest-os-version>-linux.tar.xz 
cd ghc-<latest-os-version>
./configure

Did I make install ? I do not recall.

Cardano-node stuff

At that point I have 2 cabal executables on the VPS.

  • /usr/bin/cabal --version --> 2.2.0.0
  • home/foouser.cabal/bin/cabal --version --> 3.2.0.0

Install

I made sure to use a cabal>=3 by default, and then I check for the latest tag of the cardano-node git
projet

git clone https://github.com/input-output-hk/cardano-node.git 
cd cardano-node
git fetch --all --tags
git checkout tags/<latest-tag>
cabal install cardano-node cardano-cli  --installdir=$HOME/.local/bin

Run

Before I tried, yet another launch, I quickly checked the cardano-node/scripts. The README.md and picking an eye in the scripts’s code was very instructive.
Then a simple

cardano-node run --cabal

Cabalinnistic ! it’s a live !

Conclusion

It’s probably time I understand what I did, and what to do next. Do I even have a wallet ?
@misteraxyz’s link is the way to go next!

Thank you

2 Likes

This should also be a gold mine for you :

2 Likes

Great thank you.

Hi there,
Not sure where to post it.
This is Centos8 , and I keep creating different semilinks with the same errors as below:
/.cabal/logs/ghc-8.6.5/cs-ledger-0.1.0.0-b4687c7dd021a0a183d2aa308350820b5cd6cbc6f740fc2b65971d52f9879eec.log
):
Configuring library for cs-ledger-0.1.0.0…
/usr/local/lib/ghc-8.6.5/bin/ghc: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/usr/local/lib/ghc-8.6.5/bin/ghc: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/usr/local/lib/ghc-8.6.5/bin/ghc: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
/usr/local/lib/ghc-8.6.5/bin/ghc-pkg: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/ghc-pkg)
/usr/local/lib/ghc-8.6.5/bin/ghc-pkg: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
Preprocessing library for cs-ledger-0.1.0.0…
Building library for cs-ledger-0.1.0.0…
/usr/local/lib/ghc-8.6.5/bin/ghc: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/usr/local/lib/ghc-8.6.5/bin/ghc: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/usr/local/lib/ghc-8.6.5/bin/ghc: /lib64/libtinfo.so.5: no version information available (required by /usr/local/lib/ghc-8.6.5/bin/…/terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
[ 1 of 16] Compiling Hedgehog.Gen.Double ( src/Hedgehog/Gen/Double.hs, dist/build/Hedgehog/Gen/Double.o )
[ 2 of 16] Compiling Ledger.Core ( src/Ledger/Core.hs, dist/build/Ledger/Core.o )
[ 3 of 16] Compiling Ledger.Core.Omniscient ( src/Ledger/Core/Omniscient.hs, dist/build/Ledger/Core/Omniscient.o )
[ 4 of 16] Compiling Ledger.GlobalParams ( src/Ledger/GlobalParams.hs, dist/build/Ledger/GlobalParams.o )
[ 5 of 16] Compiling Ledger.Core.Generators ( src/Ledger/Core/Generators.hs, dist/build/Ledger/Core/Generators.o )
[ 6 of 16] Compiling Ledger.Util ( src/Ledger/Util.hs, dist/build/Ledger/Util.o )
[ 7 of 16] Compiling Ledger.Update ( src/Ledger/Update.hs, dist/build/Ledger/Update.o )

src/Ledger/Update.hs:1:1: error:
Exception when trying to run compile-time code:
/tmp/cabal-install.-190864/dist-newstyle/tmp/src-190864/cs-ledger-0.1.0.0/src/goblin_genomes/UPIREG_UPREGFailure_DoesNotVerify: openBinaryFile: does not exist (No such file or directory)
Code: mkGoblinGens
“UPIREG”
[“UPREGFailure_DoesNotVerify”, “UPREGFailure_NotGenesisDelegate”,
“UPREGFailure_UPVFailure_AVChangedInPVUpdate”,
“UPREGFailure_UPVFailure_PVChangedInSVUpdate”, …]
|
1 | {-# LANGUAGE DeriveAnyClass #-}
| ^
cabal: Failed to build cs-ledger-0.1.0.0 (which is required by exe:chairman
from cardano-node-1.9.3, exe:cardano-cli from cardano-node-1.9.3 and others).
See the build log above for details.

This reminds me of an error i got when trying to compile cardano with the wrong cabal version. check that you are using “cabal 3.2.0.0” and not something more recent.

Other than that I have no clue and would recommend following either
the StakePool COURSE School or the official documentation for SPO

Your ncurses library (prerequisite dependencies on OS) are missing, please raise a seperate thread for issues in Staking & Delegation section of forum.

1 Like

Hello sir can i restore my ada coin by using atomic wallet cardano private key to daedalus wallet?

yes its 3.2.0
cabal --version
cabal-install version 3.2.0.0
compiled using version 3.2.0.0 of the Cabal library

thats what I thought, but I am certain I have it. I reinstalled it again, but to no avail.
I opened new thread already.

Thank you

I don’t think so but if it’s the same number of words you could try it. If you get either invalid phrase or empty wallet it hasn’t worked. In future please either post to a relevant topic or create a new topic, do not post to a different topic.

1 Like

Welcome @rolan great to see you here :vulcan_salute: