After rewards withdraw -> address has changed

I am running a stake pool. Months ago I created a block and received rewards. At that time I had problems to withdraw the rewards to my account with cntools. My reward account is secured with a Ledger wallet and I imported the wallet into Yoroi. Then I could withdraw the rewards to the account and could send it to another address inside the Yoroi application. All good.

Now, I created another block and I wanted to repeat it again in exactly the same way. But now, a new address was created when withdraw the rewards and there are now the rewards and the ADA that came from the “old” address on the new address.

When I import the Ledger wallet again it is syncing more than 30 minutes and does not come to an end.

How can I access the ADA on the new address?

Your pool wallet for rewards is secured by ledger? I think I don’t understood your issue … :frowning:

the wallet has more addresses and each time when u will use an address another new one will be generated… but all addresses should belong to the same wallet

Yes, the rewards wallet is secured by ledger.

I also got a little further. I entered the new address in priv/wallet/RewardWallet/base.addr. Now I can see the correct balance if I list the wallets.

Now I tried to transfer the ADA from the rewardsWallet to the pledgeWallet with cntools and I received this error:
Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash “1801c59e2026aac…7f5387”]))))])

I guess I need to sign something with the new address, don’t I?

why are u changing cntools address when u can connect the ledger on or yoroi and withdraw the rewards from there? And if u already withdrew the rewards u can also sent the funds from there… to which address/wallet u want

The BP is local or VPS?

The Problem is, after withdraw the rewards, in Yoroi the wallet is no longer synced. I tried to import the wallet in another browser. But even there it is not synced to the end.

Therefore I tried to do the transaction in cntools, but there is another problem while the transfer I need to figure out.

Now I tried to Import the wallet in adalite. Lo and behold, it is displayed correctly and I could transfer the ADA.

Thanks Alex for your help. Your questions got me on the right track.

The question remains why the Yoroi wallets are not synced, but I can now find out in peace

1 Like

Delete the wallet from yoroi (if the funds are on ledger) and pair/restore again the ledger… should work