Cabal fail to build Cardano-cli on UTM

Hi guys, I’m trying to build a Cardano-cli on linux server & UTM. However, when I execute the command below, an error called “couldn’t figure out LLVM version Make sure you have installed LLVM 9” occurs.
Do you guys know the solution?
I’m using ps.mac M1, so I’m working on UTM.


Did you mess the part of the error message that said:

Make sure you have installed LLVM 9

ie sudo apt install llvm-9

I tried to run “sudo apt install llvm-9,” but the above error is still occurring…

What was the result of sudo apt install llvm-9 ?

This is a good working order…

Besides UTM, I tried it on the docker but I failed.
Is it because my computer is M1 silicon?

Probably, Would have been really useful if you had mentioned that at the start.

Thank you for answering.
You were so kind.
Have a good time.

No virtualization expert here, but doesn’t UTM do full hardware virtualization through QEMU? How can it be related to M1? To me it seems more like some $PATH misconfiguration or something similar?

Please install libnuma-dev before getting ghcup and installing cabal & ghc.

sudo apt install libnuma-dev

Yea it’s not related to the virtualization - follow these instructions. Worked for me!
Installs and symlinks for fix:

$ sudo apt install clang-9 libnuma-dev
$ sudo ln -s /usr/bin/llvm-config-9 /usr/bin/llvm-config
$ sudo ln -s /usr/bin/opt-9 /usr/bin/opt
$ sudo ln -s /usr/bin/llc-9 /usr/bin/llc
$ sudo ln -s /usr/bin/clang-9 /usr/bin/clang