Can't stop/start Cardano Node - Unable to resolve host

Hey everyone,

Ran into an error I haven’t seen before where when I run the sudo systemctl, I am unable to resolve my host IP : Temporary failure in name resolution…

I tried looking online but I can’t seem to find the fix


What’s the content of /etc/resolv.conf

…also do you allow outbound connections just for some specific ports or for all?

Hey @mcrio there is no file ore directory

For all tcp

If there is no /etc/resolv.conf then add it with content:


and restart the dns resolver service: sudo systemctl restart systemd-resolved.service

Then try pinging some domain… ie ping

1 Like

I will try that later on. Thanks again @mcrio

Hey @mcrio

Screenshot from 2021-09-16 18-53-42

Resolv.conf is in red and when i try to sudo nano into it to add nameserver it gives me this…

Screenshot from 2021-09-16 18-55-05

It’s probably a symlink.

ls -l will show you where it points to.

Type cat /etc/resolv.conf and see what the content is.

No such file or directory, and when I try to restart enable systemctl, its unable to resolve host

a bit confused as it’s displayed above in your screenshot.

does ls -la /etc show it?

You mean restart the cardano node or some other service?

1 Like

Screenshot from 2021-09-16 19-09-34

Found my problem…
I Had to go into /etc/systemd/resolved.conf and configure the dns to
and restart the systemd-resolve.

Thanks for pointing me in the right direction @mcrio

1 Like