Cardano CLI Transaction Submit Error

I am trying to send tokens from a wallet that I created with cardano-cli/cardano-wallet and I keep getting the following error when I try to sign the transaction:

»   Error: Command failed: transaction submit error ShelleyTxValidationError ShelleyBasedEraBabbage (ApplyTxError
 »   [UtxowFailure (FromAlonzoUtxowFail (WrappedShelleyEraFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList
 »   [KeyHash \"99d77fdb86a38891859d5318704fe13ecd5a1c69a8eb8a7551e83f47\"]))))),UtxowFailure (UtxoFailure
 »   (FromAlonzoUtxoFail (ValueNotConservedUTxO (Value 1211110 (fromList [(PolicyID {policyID = ScriptHash
 »   \"7f0fc37cb501883973f38fc204785a5c11b5afb6aabaa0dc34317cdc\"},fromList
 »   [(544d544e73616e67616e6972614e363730,1)])])) (Value 2247479 (fromList [])))))])

I am not sure what this error means, there is currently 7ADA in the wallet I am trying to make the transaction with.

1 Like


Can u share how u created the transaction?


This tells you that the sum of outputs plus the transaction fee is not equal with the input(s).
You need to calculate again (or to use cardano-cli transaction build, which calculates automatically the change).

1 Like

Hello, thank you for your reply, here are the commands that I used to make the transaction. Also for a bit more context, I initially created the wallet and transferred some funds to it from my Nami wallet to test it but I have generated different payment addresses in the cli since I initially created the wallet as I was unable to transfer the funds back out of the wallet using the cli. I even tried to restore the wallet on Yoroi but when I did that it said that there was 0ADA in the wallet which confused me. I contacted Yoroi and they said that maybe it was because the wallet had multiple accounts or addresses that’s why the one that I restored had 0ADA in it even though I sent funds to the initial payment address that was generated in the cli when I first created the wallet. Just a quick sidenote, I am using the Blockfrost CLI as I cannot set up a node myself as my PC is really crap.

Command #1
bcc transaction build-raw --tx-in 9f1d2fb4c40ea0c58f6ecda71b88e6719c8050fbc658293cd1284d13a3969c9f#0 --tx-out addr1qxvawl7ms63c3yv9n4f3suz0uylv6ksudx5whzn4285r73asv5q3gwe20407vmz2jjkrvmj299x2wj089e0rqwtmqq0q8fhxxt+0 --tx-out addr1q87mdjtg85m38gkfm0xgxhnt23l8rcgx8hwrud7zqkgf9qc6q2p2j5jc53298jsh0mz83ua985waezz036kwxntwa65slaww6a+0 --invalid-hereafter 83977707 --fee 0 --out-file Wallet\Keys\tx.tmp

Command #2
bcc transaction calculate-min-fee --tx-body-file Wallet\Keys\tx.tmp --tx-in-count 1 --tx-out-count 2 --mainnet --witness-count 1 --byron-witness-count 0 --protocol-params-file Wallet\Keys\protocol.json

Command #3
bcc transaction build-raw --tx-in 9f1d2fb4c40ea0c58f6ecda71b88e6719c8050fbc658293cd1284d13a3969c9f#0 --tx-out addr1qxvawl7ms63c3yv9n4f3suz0uylv6ksudx5whzn4285r73asv5q3gwe20407vmz2jjkrvmj299x2wj089e0rqwtmqq0q8fhxxt+1034345 --tx-out addr1q87mdjtg85m38gkfm0xgxhnt23l8rcgx8hwrud7zqkgf9qc6q2p2j5jc53298jsh0mz83ua985waezz036kwxntwa65slaww6a+1034345 --invalid-hereafter 83977707 --fee 178789 --out-file Wallet\Keys\tx.raw

Command #4
bcc transaction sign --tx-body-file Wallet\Keys\tx.raw --signing-key-file Wallet\Keys\payment.skey --mainnet --out-file Wallet\Keys\tx.signed

Command #5
bcc transaction submit --tx-file Wallet\Keys\tx.signed --mainnet

This is ur cli wallet? It looks like u have also 1 asset inside the wallet which probably must be included… and as @georgem1976 already said… use build instead build-raw

Btw, which guide do u follow?

Oh yeah that’s probably the issue, I didn’t know how to include that in the transaction. I literally only started learning how to use the cli like 4 days ago. The guide I initially followed was this one here
Then yesterday I stumbled upon this and I just took the cli commands out and ignored the rest and that’s how I got the error above.

Check this topic

I’ve had a look at it but as I said I literally only started learning this 4 days ago and I barely understand what is going on. Would you be able to help me reconstruct my code because I’m clearly doing something wrong. Do you need my utxo query output?

Yeah, share it

OK thank you

TxHash TxIx Amount ──────────────────────────────────────────────────────────────── ────── ──────────────────────────────────────────────────────────────────────────────────────────────────────────────── fa5cfd8fbe444eccb6a82c934ffa30cb4d83c3dbb5affff122ef246d1f43f966 0 2000000 lovelace 8b77fc0a85753a3cb3e56ffd8bf4aabdecbd43c07cfcb3e61a7fe21684e3854c 0 2000000 lovelace 9f1d2fb4c40ea0c58f6ecda71b88e6719c8050fbc658293cd1284d13a3969c9f 0 1211110 lovelace + 1 7f0fc37cb501883973f38fc204785a5c11b5afb6aabaa0dc34317cdc.544d544e73616e67616e6972614e363730 81938fe21158956b790bba16019641689ce6cea58da93dbab5f69f2f1039a452 0 1800000 lovelace


Should be something like this :slight_smile: (it will send all funds)
Please check again if the destination address is addr1q87mdjtg85m38gkfm0xgxhnt23l8rcgx8hwrud7zqkgf9qc6q2p2j5jc53298jsh0mz83ua985waezz036kwxntwa65slaww6a

bcc transaction build --mainnet \
--tx-in fa5cfd8fbe444eccb6a82c934ffa30cb4d83c3dbb5affff122ef246d1f43f966#0 \
--tx-in 8b77fc0a85753a3cb3e56ffd8bf4aabdecbd43c07cfcb3e61a7fe21684e3854c#0 \
--tx-in 9f1d2fb4c40ea0c58f6ecda71b88e6719c8050fbc658293cd1284d13a3969c9f#0 \
--tx-in 81938fe21158956b790bba16019641689ce6cea58da93dbab5f69f2f1039a452#0 \
--tx-out "addr1q87mdjtg85m38gkfm0xgxhnt23l8rcgx8hwrud7zqkgf9qc6q2p2j5jc53298jsh0mz83ua985waezz036kwxntwa65slaww6a+1500000+1 7f0fc37cb501883973f38fc204785a5c11b5afb6aabaa0dc34317cdc.544d544e73616e67616e6972614e363730" \
--change-address addr1q87mdjtg85m38gkfm0xgxhnt23l8rcgx8hwrud7zqkgf9qc6q2p2j5jc53298jsh0mz83ua985waezz036kwxntwa65slaww6a \
--out-file tx.raw
bcc transaction sign --mainnet \
--tx-body-file tx.raw \
--signing-key-file payment.skey \
--out-file tx.signed
 bcc transaction submit --mainnet \
--tx-file tx.signed

I used the first command, the transaction build one and I got this error.

not found in blockfrost-cardano-cli. Using installed cardano-cli version 1.35.4 instead. cardano-cli: CreateFile "\\\\.\\pipe\\cardano": does not exist (The system cannot find the file specified.)

I have the environment variable set though I don’t understand why I’m still getting this error.

Environment variable:

Because u need to export the variable path

Is the node synced?

export CARDANO_NODE_SOCKET_PATH=/home/user/cardano/db/socket

replace the socket path with ur socket path

No that’s my problem I can’t sync the node because my PC is low on RAM and can’t handle running a node, hence the reason why I’m using the blockfrost cli.

Do I just export it in the command line? Or where do I run that export command? Sorry for the noob questions.

can u try

bcc cardano-cli transaction build --mainnet \

I got this error

not found in blockfrost-cardano-cli. Using installed cardano-cli version 1.35.4 instead.
Invalid argument `cardano-cli'

Usage: cardano-cli
            ( Era based commands
            | Byron specific commands
            | Miscellaneous commands

Ok, u want to send all funds? I’ll try to make it with build-raw

Dear Ralph, we started a project last year that I think you may find interesting in the long term. We are going to submit a Proposal for Catalyst F10. The idea we are calling Integrated Centralized Error Management, or ICEM. With ICEM, we centralize the reporting, lookup, research, and solutioning of errors like the one you got in Cardano-CLI. The software, instead of presenting you with some esoteric error code (God, try to understand that garble!!), will also present you with the ICEM-provided input from the community on what it means, and how to solve it, as well as the error code. The solution is called CodaEA, which AlexD is also piloting on scanning the Cardano logs and identifying/reporting issues.

Our request to the community would be for IOHK to incorporate CodaEA as an ICEM system into the Cardano Node code, so that when it reports an error, it also references community input and links (e.g. to this forum) along with the code.

If you like this idea, please look for us when Fund10 gets underway and vote your support!