Cardano-node-services - LOADING - should I run something else?

and if u ar typing now journalctl -e -f -u cardano-node

what do u see?

glive still shows starting?

gLive still is starting

Similar reoccurring lines. The one line that stands out is:
May 30 14:48:39 wind cardano-node[449891]: cardano-node: FatalError {fatalErrorMessage = “Cardano.Node.Run.handleSimpleNode.readTopologyFile: Is your topology file formatted correctly? The port and valency fields should be numerical. Error in $: endOfInput at ‘]’”}
My topology file is the text you sent over earlier.

Here’s a sample screenshot:

can u attach a picture with the topology file?

Looks ok… I think it’s syncing now, can u locate the socket file?

did u started the node with cnode port 6001?

I changed ENV
image

then ran script ./cnode.sh

my ufw is set to 22 and 6001

Ok, and if u go to sockets folder, do u see the node0.socket file created?

no, sockets folder is empty :frowning:

Strange, wait…

Can u try to uncomment the socket line from env (delete # from the beginning)

and type


echo export CARDANO_NODE_SOCKET_PATH="$NODE_HOME/db/socket" >> $HOME/.bashrc

source $HOME/.bashrc

then restart the node

sudo systemctl restart cardano-node

ok will try that
image

chris@santonode:~$ sudo systemctl restart cardano-node
Failed to restart cardano-node.service: Unit cardano-node.service not found.

This seemed work, stop then start then status, looks like it restarted
image

I can’t locate the socket file… how can I? Or what should I add? Status is still “starting”

ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 1148774 ) is not listening on this port. Please update the config or kill the conflicting process first.

ERROR: gLiveView failed to load common env file
Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub

Restart the server

I did… now ./gLiveView.sh isn’t working… are you familiar with this error?
./gLiveView.sh: line 1: 400:: command not found

Screenshot 2021-05-31 at 12.09.36

sudo systemctl status cardano-node

Still running…