Catalyst not compatible with my phone (or vice versa)

I was not able to find a way to participate in the Catalyst Fund voting without a smart phone. I was told that it is mandatory. It’s a pity. I tried to use my smart African phone, but Google play says my phone is not compatible with this app version.

I think it should be important for the decentralisation process not to force people to use new smart phones. Although many people have smart phone in Africa, we still use internet café and I would not expect too much from the quality of the smart phones we generaly use in my country. Mine is not that bad (Original SamSung SM-G360F with Android 5.02) but already not compatible with Catalyst !

1 Like

I don’t understand why voting isn’t built into the Daedalus Wallet.

1 Like

I totaly agree and I wonder if it’s not a way to bootstrap KYC.

1 Like