sync error: failed to fill whole buffer

Hello Community, I am getting the following error when running sync on my core machine. May be an issue after upgrading to 1.29.0 as I have never seen this before. Any ideas on how to fix it?

sync error

Update the script

For cntools users

cd ~/tmp
./ -c

Done, but still have the error, updating the script installed the latest version of Rust which I thought would fix the problem. Do I need to restart the machine?

I can see that if I run again it shows version 2.1 is installed instead of v4. For some reason the update is not overwriting the old version. I renamed my scripts folder and ran again as you mentioned in this post How to update cncli to the latest version on Github for Cntools users? - #4 by DenisHR1 but still no joy. I updated my env file after the new scripts folder was installed.

command -v cncli


cncli --version

cncli 4.0.0

because u need to run -c … did u ran it this way?

yep, several times

working now, I deleted the scripts folder again and then ran -c, error gone! Thanks Alex.

1 Like

Nut now u must edit the env file… did u edited back right?

yep did that, there was only a couple of variables that needed changing. Also changed the script to use 4 cores.

hmm, how many cores does it use by default? and how did u changed it? thank you
I thing I saw with htop that it’s using all cores but not same time…


is the default value. I changed it to:


as my machine has 4 cores. I’m not sure how many it uses by default, I assumed 2

1 Like

In version 1.30.1 I don’t see CPU_CORES, was it removed?

1 Like

did u mean inside the script?