Daedalus doesn't show my pool for more than 10 days, SHASM server outputs URL error, but other services have no problem

Unfortunately I have no idea what to check more. keep us posted, super interested to find out where problem is.

Problem solved.
IOHK asked me for the URL of the metadata, so I submitted it. After that, the problem was solved.
I don’t know if the problem was solved by submitting the metadata URLs or by further patrolling of the SMASH server, but I am relieved that the problem has been solved.

@Alexd1985
Before and after submitting the metadata URL to IOHK, I checked it again using the criteria you provided.
Thanks for the detailed criteria.

@os11k
Thank you for keeping up with the detailed reports along the way.

A supplementary note for those who have run into similar problems

You can use the SMASH server API to check if the meta information is registered in the database.
For example, here is the URL

curl -X GET https://smash.cardano-mainnet.iohk.io/api/v1/metadata/383dd348581c3c16a981de1178c42f1d3134280f66bed7518b772ffd/8d9d155065262c372d2d6bf4ac566e3a3208df5eb4a33d0a574d644697b2623f

Even after the problem was solved, we sometimes received responses that the meta information was not registered in the database.

So, if you query the API regularly, you will be able to know the solution to your problem quickly.
However, since this API seems to have access restrictions, it would be best to avoid multiple queries in a short period of time.

2 Likes

Hi,

I am getting the same issues, where every website like pool.vet adapools.org etc approve the metadata link, its hash, and the registered metadata hash. Only Daedelus can’t find the pool, as the hash is not in the DB according to this request curl -X GET https://smash.cardano-mainnet.iohk.io/api/v1/metadata/f1ae552b032c2d87a416f4067eaf4636b3fe5e80230a1f63aa33f6bc/d843ac7c8ab3a17fe28d5a68c975dc846fe87479364bcff7dd3b30e5c442ca07

I also manually hashed the output of the registered link and it outputs the same as what was registered. It’s been about 1.5 days since the metadata update.

Here is a link to adatools showing a metadata check at the bottom ADATools.io

Hi,

Please contact IOHK support

https://iohk.zendesk.com/hc/en-us

click on ? → write something (for example pool) → contact us and fill the form

Cheers,

1 Like

I’m having the same exact issue. Thanks for this thread. I will have to contact them as well

I’m having the same problem (ADAR). I never use Daedalus anymore, so not sure for how long this has been a problem. It’s such a cursed tool. The bane of small pools everywhere.

No problems w/ other wallets. No problems w/ site info tools like adapools, pooltool.io, etc. No problems per pool.vet. Only DAEDALUS.