Daedalus for Shelley testnet; first version out today for stake pool operators

Today, we’re releasing our first Daedalus version for the Shelley testnet.

Daedalus 1.0.0-STN1 offers just basic functionality, designed purely for stake pool operator testing. So regular ada holders don’t need to do anything for now. More features will be added prior to a release being made more widely available. Nevertheless, this release is an important early milestone on the Shelley Daedalus wallet journey. It is the first Daedalus release that is compatible with the Shelley (Haskell) testnet and the first iteration in a series of wallets that will – over the course of the rollout – become the wallet that all ada holders will ultimately use on the Shelley mainnet.

This first version of Daedalus will allow stake pool operators to test basic wallet functionality. It supports the creation, deletion, and restoration of Shelley wallets and transacting on the network. Shelley wallets can also be funded using the Shelley Testnet faucet. Since this is not a release for the general ada holder, this version of Daedalus is accessible only via our GitHub repository. In time, later versions will be provided via the usual web download.

If you are a stake pool operator running a pool on the testnet, we encourage you to download this version of Daedalus and give it a try. Although functionality is currently basic, getting feedback is a helpful early input into our development process. We particularly encourage stake pool operators to try the following:

  1. Start the Daedalus application and create two new wallets
  2. Sync the chain and record how long it takes - note: this is an area where we anticipate significant optimisation in the next release
  3. If you already have some test ada, use the node CLI to fund one of your wallet addresses, otherwise obtain funds from the Faucet for one of the 2 wallets
  4. Create a transaction in Daedalus to send funds from the funded wallet to the other
  5. Check when the transaction has succeeded - please note the time
  6. Create an additional 5 separate transactions over a 24 hour period to send funds to yourself or to other Testnet users, and create occasional transactions from then on; note: the network isn’t yet optimised for ‘stress testing’ (there is no value in this at this point) but this will give us a good sense of ‘normal’ usage

During the Shelley rollout, new features will be added to Daedalus for the Shelley testnet, including viewing stake pools, delegating stake and checking earned rewards. We will also add support for legacy Byron wallets and moving all funds from legacy Byron wallets to new Shelley wallets. We’ll be sure to keep you posted as each new version is released.

A quick update on the wallet backend

So that’s Daedalus. Meanwhile, another critical piece of work is continuing as part of the overall wallet rollout plan.

The Adrestia team is busy finalizing the integration testing of the wallet back end to the Shelley Public testnet and readying all Shelley features for stake pool operator testing.

The features that will first be available for testing by stake pool operators are:

  • Shelley-format transaction creation and submission
  • Checking rewards earned on the Haskell testnet (not the ITN rewards)
  • Checking the list of “registered” stake pools
  • Delegation to stake pools

Stake pool operators who have already been running a pool on the Incentivized Testnet (ITN) will be familiar with these operations – these are the same features that are currently available on the ITN.

Once initial testing and QA has been satisfactorily completed, these features will be integrated into the next release of Daedalus (itself following its own development track). This way we can continue to run our development activities in parallel; testing ‘raw’ back end functionality before implementing it into the Daedalus GUI.

If you encounter any bugs, issues, or concerns–or if you have feedback–please leave it here in this thread! Feedback and questions that need developer responses will only be seen if they are posted here. We will respond to questions and concerns in this thread as we are able.

Pool operators should note that the first focus is to support the Shelley features. The “Byron” part of the API isn’t expected to work at this time. Those functionalities will come into play once we have finalized the work on transaction witnesses in cardano-node still underway.

Remember to subscribe to IOHK’s YouTube channel for the regular updates on our development progress from Cardano delivery lead, Christopher Greenwood. We’ll also keep you up to date here with all the latest news – so stay tuned!


So far. Created two wallets and block chain was sync’ing slowly; 2% in ~8 mins. Then hit the dreaded network connection lost. Kicked the node over a couple of times with restart and have closed and restarted wallet; but stuck on 0%. I’ll keep trying.

Just deleted and uninstalled. Wallet recovery worked perfectly (for keys; can’t vouche for sync of them yet)! Now allowing to synch again.

Hit the lost connection again, at epoch 8 | slot 14769 (although the last network is keeping up!).

Seeing a lot of these in Node.log:

[34m[DESKTOP-:cardano.node.BlockFetchDecision:Info:36]e[0m [2020-06-16 18:12:40.16 UTC] [String “PeersFetch”,Array [Object (fromList [(“peer”,String “ConnectionId {localAddress =, remoteAddress =}”),(“kind”,String “FetchDecision declined”),(“declined”,String “FetchDeclineReqsInFlightLimit 100”)])]]

Is there a limit on the number of fetches?


Welcome @CrazyCareer to the community great to see you here

1 Like

iMac prepares for take off, at least that’s what the noise suggests.

cardano-cli 1.13.0 - darwin-x86_64 - ghc-8.6
git rev 0000000000000000000000000000000000000000

Since the wallet uses the same cardano-node under the hood, it has the same current issues.

  1. First load:

The bootstrapping time is very slow, the more epochs go by the longer it takes. Today I installed a new relay, it took 2h 10m to get to tip using my own relays. A fellow CTA member did the same and it his relay took 5h to be on tip.

CPU is 200% when loading the chain via the network. More relays on the topology.json mean slower load times.

Wallet specific:

200% CPU, loaded 2.2% in 15 minutes.

Timeouts kick in too early for this cardano-node behavior. Those timeouts “force” a Daedalus restart, which doesn’t help, because 2.

  1. Second time startup

When the cardano-node starts for the second time it seems, that it performs some kind of optimizations on the DB. The CPU is at 100% all the time. Memory consumptions increases very slowly, if at all.
Timeouts kick in too early for this cardano-node behavior. Let Daedalus run and the cardano-node will eventually (again 15-20 minutes for 2.2% chain) finish the slow optimization part and start loading the chain again.

I replaced the default IOHK topology entry with my own TITAN relays, valency 2. Since I know this will only take a little more than 2 hours.

Loaded an additional 0,5%, then closed Daedalus again.

  1. Third time startup

The same optimization process takes place for the 0.5% (about 4 minutes for that part), then chain started loading again.

Will let it run now for 3 hours, this should get the wallet on tip.


The described behavior of the cardano-node was consistent for this and the last genesis chain.

And of course this has nothing to do with the Daedalus wallet or it’s current state or features.

But people need to be aware, that the bootstrapping will take hours and even if the timeout kicks in,
just let it run, it will be on tip eventually.


Thanks for the feedback - please keep it coming. Our dev team will be checking in here from time to time so this is v useful

1 Like

Since this is just a cardano-node issue, you can just copy a snapshot of the current database into the chain folder (on macOS: /Users/username/Library/Application Support/Daedalus Shelley Testnet/chain/).

Restart Daedalus and you will be on tip after just 2 minutes and can start testing the wallet features.


Yes, the node is not yet tuned for Shelley. We are working on it right now, and will have a version of Daedalus that can be tested by normal Ada holders in the near future (with performance improvements). Meanwhile as Marcel says, if you are running a pool node, you can copy the database if you like to speed up the initial sync time. We thought it was worth passing on the current version to pool operators so they can test out the UI etc (and it may be easier for them to manage transactions etc through the Daedalus interface).

1 Like

I’ve installed 1.0.0STN1 on Ubuntu 20.04. Everything seems to work fine so far. Transactions from the Faucet or between my own Wallets took a few seconds. Only synching blocks was very slow until it reached 30% (~2hrs) but after that it went to 100% very quickly…

1 Like

It looks like the sync percentage calculation is off - see screenshot below:


Wow! 18 Seconds to transfer 100k fAda to flight wallet… :wink:

26 Seconds to transfer 50K to my second wallet !!! What did you do??? :wink:

17 Seconds from faucet to wallet!

Should of also said, I’m on a Win 10 (i9 Beast)…

1 Like

Syncing took less than 2 hours, sending tx’s are confirmed in 12 seconds. 1x tx’s sent to own wallet address and other to my stake pool. Will test some more the coming days, but it’s looking good atm. Also looking forward for the stakepool integration!


Agreed. The sync does NOT match up with the actual.

Going to bed, but before so. On my Win 10 machine. I uninstalled, deleted the state folder and then clicked on install along with the stop watch. I then completed the install, recovered my two wallets (to the Lovelace!) in 57:10.75. That, if I recall, was ITN FN4 speed! Which is remakable, given this is the first version… WELL DONE!

Rigorously tested transferring ADA to different stake pool ops and having absolutely NO problem. Transactions taking no more than 30 seconds, but on average, around the 16 sec mark! Absolutely brilliant. Lots of screenshots in twitter feed if you want to see timings.

1 Like

Hello, just tried new Daedalus and first sync took some hour, then I successfuly created two wallets and funded first one and make transaction to second wallet (took around 75s). After restart of Daedalus I had trouble with sync, after few minutes it was looking synced but no wallets visible, after another restart wallets again on place :slight_smile:

my quick Daedalus STN feedback:

– initial sync from scratch took about 1h and 15m
– transaction from my pool to transfer 100K ADA took roughly 30s
– transaction from wallet 1 to wallet 2, took about 30s as well

So far so good. The wallet is fast and stable, and it does work as expected.

I will continue with the required tests in the following days.


1 Like

Sync took a while as others have commented. However, working from home with 4G and Yagi Antenna in the countryside so bottleneck is my internet. More sheep here than fast internet!

Syncing seemed to grind initially and then sped up towards the end?

No usability issues. Opens quickly, Sends quickly, received quickly.

Wallet recovery worked nicely. Balance & Transaction History re-synced within seconds after recovery

Played a few games of ‘Daedalus STN Tennis’ :tennis: with other Stakepool Ops and transactions all happened quickly. Longest time was 45-60 seconds. Most were quicker

On a side note, it’s great to know all the manual commands to send funds but so nice to have a functional wallet available to do it quick and easy!

Linux - Ubuntu 18.04 . . .

matticus :kiwi_fruit:

Welcome @kiwipool