Did Yoroi break its Ledger support?

I was just trying to help someone get a Ledger connected to Yoroi, but I get stuck at the same screen:

Ledger works without problems with Adalite and ccvault in the very same Chromium window. It worked before with Yoroi in the same browser.

I had the same problem. I found something on github claiming that the ledger connection was broke. I can’t find it but eventually Daedalus worked. It should have been fixed, make sure it’s the latest version. I believe there are fake wallets out there so make sure you grab the real thing. Go to the official site and follow the links. Someone uploaded some fake wallet to google store.

It already was the latest version, but uninstalling and installing it from scratch fixed it anyway.

I’m sooo close to actively advising against Yoroi (and Nami). Horrible design decisions, horrible bugs, horrible support (driving people to scammers in huge numbers).


Hmm… Weird. I hear there will be better versions of yoroi and Daedalus when the basho stage is complete. I sure hope so for the same reasons you mention.

1 Like