ERROR 500: Internal Server Error

Hello everyone,

I was just updating my node issuing the following command:

wget -N https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-byron-genesis.json

And am getting ERROR 500: Internal Server Error

Is something up with iohk's server?

Thanks,
Stu

Whats the final Url you are using in wget?
echo "https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-byron-genesis.json"

https://hydra.iohk.io/build//download/1/mainnet-byron-genesis.json

I updated my 2 relay nodes yesterday using the exact same command w/o any issues.

wget -N https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-byron-genesis.json

$NODE_BUILD_NUM is not set, so that’s an invalid URL. (Strange to give a 500 on that, though, should be 400 or 404.)

1 Like

Yea. The script is still parsing the empty build number script. Seems no validation around that :slight_smile:

As @HeptaSean mentioned you need to set the NODE_BUILD_NUM env. variable.
export NODE_BUILD_NUM=build_number_here

1 Like

If you click on the link it says “Invalid build ID ‘’.” So, it does know that it is a client error.

yeah right… http 500 is definitely off :slight_smile:

1 Like

Thanks very much guys. Still a bit confused as to what exactly I have to do. Is this an error on my side or iohk’s server?

Again, that wget command is the one I have been using since I started this Cardano SPO journey. :slight_smile:

It’s on your end. Where in the process is the NODE_BUILD_NUM environment variable set? (it’s the one missing so you are getting the error)

1 Like

Ok thanks very much! I’ll look into where I went wrong. :frowning:

Still stumped…

These are the instructions I’m following to upgrade from 1.32 to 1.33. I’ve updated the server, set cabal to 3.4.0.0 and ghc to 9.10.7, built the cardano-node to 1.33, stopped the cardano-node service, and now am trying to install 1.33.0 using the following commands:

sed -i $HOME/.bashrc -e "s/export NODE_BUILD_NUM=.*/export NODE_BUILD_NUM=8111119/" 
source $HOME/.bashrc
cd $HOME/cardano-my-node
cp mainnet-byron-genesis.json mainnet-byron-genesis.json.bkp
cp mainnet-shelley-genesis.json mainnet-shelley-genesis.json.bkp
cp mainnet-alonzo-genesis.json mainnet-alonzo-genesis.json.bkp
cp mainnet-config.json mainnet-config.json.bkp
wget -N https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-byron-genesis.json
wget -N https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-shelley-genesis.json 
wget -N https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-alonzo-genesis.json 
wget -N https://hydra.iohk.io/build/${NODE_BUILD_NUM}/download/1/${NODE_CONFIG}-config.json
sed -i ${NODE_CONFIG}-config.json -e "s/TraceBlockFetchDecisions\": false/TraceBlockFetchDecisions\": true/g"
sudo cp $(find $HOME/cardano-node-1.33.0/dist-newstyle/build -type f -name "cardano-cli") /usr/local/bin/cardano-cli 
sudo cp $(find $HOME/cardano-node-1.33.0/dist-newstyle/build -type f -name "cardano-node") /usr/local/bin/cardano-node

Typo…set ghc to 8.10.7

These lines should set $NODE_BUILD_NUM, but only if there already was an export NODE_BUILD_NUM line in your .bashrc. If you edited it by hand or followed a slightly other guide, when setting up that node or … that line may not be there.

(That’s why I don’t like these copy and paste guides.)

Edit your .bashrc with your favourite editor, put export NODE_BUILD_NUM=8111119 in there (at the end if you do not have any other preference), and either do the source $HOME/.bashrc or just open a new terminal. Then $NODE_BUILD_NUM should be set.

Thanks HeptaSean! That worked! And it also gave me a chance to clean up A LOT of duplicate lines in my .bashrc. :slight_smile:

I’ve followed the Coincashew guide and up until now everything had been working fine. I would say my understanding of Linux and it’s commands and structure is at a beginner to intermediate level. This explains my inability to decipher error codes and troubleshoot accordingly. With an awesome Cardano community comprised of helpful folks like yourself and others…I keep learning every day!

Thanks again!

1 Like