Got "atLeast" script value not found while trying to create a native token issuer address

root@cardano-mainnet:~/yautoken# cat issuer.script 
{
    "scripts": [
        {
            "keyHash": "5820d55570da9ecfc86614563782549a0300b05f44fd935a46b1ad7bd21c196b840b",
            "type": "sig"
        }    
    ],
    "type": "all"
}
root@cardano-mainnet:~/yautoken# cardano-cli address build-script --script-file issuer.script --mainnet --out-file issuer.addr
Shelley command failed: address build-script  Error: Error decoding multisignature JSON object at: issuer.script Error: Error in $: "atLeast" script value not found
root@cardano-mainnet:~/yautoken# cardano-cli transaction policyid --script-file issuer.script 
Shelley command failed: transaction policyid  Error: issuer.script: Error in $: "atLeast" script value not found

Sorry it’s my fault, I use the vkey itself instead of hash of the vkey in script file.

The error message mislead me.

1 Like

I got the same error earlier, took some time to figure it out with that output.

Hey can you tell me the solution
I got the same error
My keyhash is also empty

generate key hash using command cardano-cli address key-hash --payment-verification-key-file policy/policy.vkey, don not just open policy.vkey and copy paste its content.

I solved that but what about that error?

i had the same error, for me it was a before object

{
  "slot": "23327325",
  "type": "before"
}

the problem were the quotes around the slot number, because it’s a number not a atring