Host address means...?

So I’m following the directions for the testnet BP setup (, and I’ve created my payment address and tested it by doing the command that brings up the dotted line --------------------------------------- showing Tx hashes of payments underneath the line.

When I went to the test-ADA faucet to request that some ‘ADA’ be sent to my payment address, I never received the ‘ADA’, so I have to wait another day to request some more. The Tx showed up as being sent to the correct payment address by the faucet, but looking under the payents on my relay, the transaction hash never appeared.

‘Host address’ on the test net instructions means my public IP address, so it can’t be an address on my local network that doesn’t connect to the outside world, right?, because those addresses are private, reserved for local network, so I thought they meant default gateway IP address even though it’s private, it’s the last IP address in your LAN that is still part of your LAN. Once you go beyond that address, you’re connect to some other network I suppose, right? Sorry, I’m new to this stuff.

The directions for the test network say to use “TPraos” protocol, so I did, and the host address I used was my public IP address which I guess is default gateway IP address.

So I use my gateway IP of the form, 72.x.x.x along with TPraos protocol, but never received the ‘ADA’, so for tomorrow, lol, I want to avoid not getting the ‘ADA’ and having to wait yet another day to request some more.

I don’t know what TPraos is used for? Does that protocol belong to ITN, and if so, then shouldn’t I be using ‘Cardano’ test net instead?

The instructions on the test net show a picture where the person doing the setup didn’t even specify his host address, he just used the relay’s db socket, and after starting his node, his hostname which is supposed to resolve to his public IP appeared to show up as his loopback IP address (, so I’m thoroughly confused now since testnet instructions mention ‘host address’ as ‘public IP address’:

Maybe port forwarding is involved to get the payment from the router to the computer hosting the BP node?

Still learning. :confused:

Sorry for lengthy post, but I want to avoid mistake of today, and have to wait another day to get some test-ADA.

It’s solved. I did the transaction this morning, and in finally shows up tonight. I still don’t know if using the gateway IP was the mistake I made, and I had to erase the database and start with the local IP 192.x.x.x or it was because I changed the protocol from TPraos to Cardano and built a new database using the local/private IP: 192.x.x.x. It doesn’t matter though…in my impatience and haste because of waiting so long for the transaction to go through and so eager to move on to something new, I accidentally overwrote the payment address and other keys with new ones earlier in the day before I could back the old ones up, so the transaction is there, but I have no access to it. :frowning:

One last comment for anyone who got stuck on this part.
First, I backed up my relay/ folder in home/ folder: sudo cp -rfvpn /relay ~/relay-bu

then erased all files in relay/ and decided to start with a new config:
TPraos protocol didn’t work for me so I switched over to ‘Cardano’ protocol, and I changed my private IP 192.x.x.x to my gateway/public IP. Then ran the node, and it started picking up the tip of blocks starting from the beginning of the chain, so once I knew it was working. I killed the node process, deleted all the files in relay/ and then put in my old files from backup with the updated config file modifications that worked on the new node I runned briefly - my old back up included the full updated database (db) I had in relay/, so I didn’t have to start building the db from scratch. When I went to run it, it picked up where it left off using the full db with the new parameters, so I didn’t know cardano node is so flexible…you can change things on the fly, and not have to rebuild the database from scratch. Anyway, finally got those test-ADA. :smiley: