Install Cardano on ArchLinux (Fails)

Hi,
Tried installing Cardano on a x200 machine with only 4 Gb of RAM, for a tryout. Clean install of ArchLinux. The software would start but would be unable to synchronize, or to verify the synchronization of time, to NTP server. I setup a NTP client, and clock was synched, but no success. By bypassing the NTP clock check, I was prompted to create a wallet. But then the process would stop at the network synchronization time. Diagnostics would indicate node was running and that there was a connection to the network but would simply not synchronize.
So, because minimum requirements were not met and they could be the root cause, I decided to try it on another machine.
Installed it on a T430 with 16 Gb of RAM. Everything seemed to install correctly, as before (no message in console). But in this machine, there is no complain about the NTP clock but the node is shown as Not Running in the diagnostics window as well as indicating that there is no connection to network. It is also a clean install of ArchLinux.
Same network, same everything.
Opened a ticked but support keeps insisting that there is a network/isp, firewall or anti-virus issue.
I don’t think so, I have been trying to verify it nonetheless.
No firewall, nor antivirus running.
Network is able to connect on TCP port 3001 to the daedalus network.
Tried running via a mobile phone tethering but same error.

I was hoping there was something I could to verify and confirm the correct installation of the software. Or perhaps some manual installation steps ?
I have installed currently simply by downloading 4.3.1 and executing in console with regular user account.

Anyone ?

That is well under the official system requirements. That will not work.

Installed it on a T430 with 16 Gb of RAM.

That should be fine, but the computer time must be pretty close to correct (within the second or so).

I have an old laptop with a dying battery that my wife uses for Daedalus and just use ntpdate to correct the date.

Yes, unfortunately the computer time issue only happens on the x200 with 4 Gb of RAM.

On the T430 with 16 Gb of RAM, there is no time issue but the node doesn’t start.

So, I just got confirmation from my ISP that they do no block any ports.

Now, … having no firewall running… having no antivirus running … having no port blocked by ISP … having seemingly all the minimum requirements … why can’t my node connect to the Daedalus network ?

So what is the error message if any?

The tool doesn’t throw any error message. It just shows the “Verifying Blockchain 0%” message.

However, I know in the other computer x200, the tool went through the process of creating a Wallet. In this computer, T430, it doesn’t even do that.

If I open the diagnostics window on the T430 it says that “Daedalus Connected: No.” “Node status: Running”, “Node responding: No”. “System Time Correct: Yes”.

However, if I open the diagnostics on the X200, it says that “Daedalus Connected: Yes”, “Node status: Running”, “Node responding: Yes”. “System Time Correct: No”. But this machine also doesn’t have enough memory so he ends up not synchronizing/validating the blockchain.

The Support ticked I opened is just being ignored as they believe its a connection issue, however I just cleanly installed both machines in the same way… only difference is one is i386 and the other x86_64. One is EFI the other is MBR. So I cannot imagine that my ISP would block some ports on one machine and not the other.

I have been trying to help, but you seem to be ok with just wasting my time.

But this machine also doesn’t have enough memory so he ends up not synchronizing/validating the blockchain.

We already know its not going to work on a machine with insufficient memory, so why are you even trying and more importantly, why are you posting it here?

All I can suggest now, it ignoring the machine that has insufficient memory, removing and reinstalling on the machine that does have sufficient memory.

What you mean wasting your time ? I have been answering every single of your requests as best as I could by providing as much detail as possible. If you have no interest in helping then I would appreciate that you don’t even bother instead of being negative against people who are struggling already…

The only point of posting about the other machine here is to provide as many details as possible and to disprove the notion that my ISP is blocking the communication.

What do you mean by uninstalling, Daedalus software ? I have done that already. Are there any official procedures for doing so that I should follow ?
I have found some instructions somewhere, cant recall if here on the forum or elsewhere that I followed for unninstall by removing some . folders where software and configuration is located. The install procedure I followed was simply ‘download .bin on daedalus.io. give it execute permission. Execute as regular user.’

Edit: these are the instructions I followed for uninstalling: https://iohk.zendesk.com/hc/en-us/articles/360013170694-How-to-uninstall-Daedalus-from-Linux

Took a windows 10 machine, and installed Daedalus. No problems whatsoever, Wallet creation screen popped up … and the node started synchin in the background.

So, it seems to me that there is definitely something wrong with the installation on (Arch?) Linux.
Some dependency missing, or something…

OK. So, the problem turned out to be related to DNS IP resolution.
Arch Linux is using a new system and apparently the way I configured it was leaving legacy applications in the dark. Everything would seem to work fine for the rest of the system.

So anyone running into this, when using systemd, make sure that, when configuring the base system you end up replacing the file /etc/resolv.conf with the symlink to the stub file.

If you want to verify you suffer from the same issue, you can check your DNS.
Using:
$ getent hosts relays-new.cardano-mainnet.iohk.
Will resolve correctly.
However, using:
$ nslookup relays-new.cardano-mainnet.iohk.io
will not resolve correctly. (note, nslookup is not installed by default in base system)