# Issue with 8.7.2 upgrade: cabal: Could not resolve dependencies

**URL:** <https://forum.cardano.org/t/issue-with-8-7-2-upgrade-cabal-could-not-resolve-dependencies/125289>\
**Category:** Operate a Stake Pool\
**Created:** [15 December 2023 08:01 UTC](https://forum.cardano.org/t/issue-with-8-7-2-upgrade-cabal-could-not-resolve-dependencies/125289 "2023-12-15T08:01:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![fenix](https://avatars.discourse-cdn.com/v4/letter/f/eb9ed0/32.png) [@fenix](https://forum.cardano.org/u/fenix)\
**Post date:** [15 December 2023 08:01 UTC](https://forum.cardano.org/t/issue-with-8-7-2-upgrade-cabal-could-not-resolve-dependencies/125289/1 "2023-12-15T08:01:37Z")

</div>

Hi, i’m trying to update to 8.7.2, when i try “cabal build cardano-node cardano-cli” i receive this error:

Resolving dependencies…

Error: cabal: Could not resolve dependencies:

[\_\_0] trying: cardano-node-8.7.2 (user goal)

[\_\_1] trying: ouroboros-consensus-0.14.0.0 (dependency of cardano-node)

[\_\_2] trying: cardano-ledger-binary-1.2.1.0 (dependency of

ouroboros-consensus)

[\_\_3] trying: vector-0.13.1.0 (dependency of ouroboros-consensus)

[\_\_4] next goal: cardano-crypto-class (dependency of cardano-node)

[\_\_4] rejecting: cardano-crypto-class-2.1.4.0 (conflict: pkg-config package

libblst-any, not found in the pkg-config database)

[\_\_4] rejecting: cardano-crypto-class-2.1.3.0 (conflict: vector==0.13.1.0,

cardano-crypto-class =\> vector\<0.13)

[\_\_4] skipping: cardano-crypto-class-2.1.2.0, cardano-crypto-class-2.1.1.0,

cardano-crypto-class-2.1.0.2, cardano-crypto-class-2.1.0.1,

cardano-crypto-class-2.1.0.0 (has the same characteristics that caused the

previous version to fail: excludes ‘vector’ version 0.13.1.0)

[\_\_4] rejecting: cardano-crypto-class-2.0.0.1 (conflict: cardano-ledger-binary

=\> cardano-crypto-class\>=2.1)

[\_\_4] skipping: cardano-crypto-class-2.0.0.0.1, cardano-crypto-class-2.0.0

(has the same characteristics that caused the previous version to fail:

excluded by constraint ‘\>=2.1’ from ‘cardano-ledger-binary’)

[\_\_4] fail (backjumping, conflict set: cardano-crypto-class,

cardano-ledger-binary, cardano-node, vector)

After searching the rest of the dependency tree exhaustively, these were the

goals I’ve had most trouble fulfilling: cardano-node, cardano-crypto-class,

ouroboros-consensus, vector, cardano-ledger-binary

Try running with --minimize-conflict-set to improve the error message.

CONFIGURATION:  
The Glorious Glasgow Haskell Compilation System, version 8.10.7

cabal-install version 3.8.1.0  
compiled using version 3.8.1.0 of the Cabal library

Any idea?

---

<div class="post-metadata">

**Author:** ![Zyroxa](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.cardano.org/zyroxa/32/17790_2.png) [@Zyroxa](https://forum.cardano.org/u/Zyroxa)\
**Post date:** [15 December 2023 08:08 UTC](https://forum.cardano.org/t/issue-with-8-7-2-upgrade-cabal-could-not-resolve-dependencies/125289/2 "2023-12-15T08:08:01Z")

</div>

Did you update cabal and did you also install BLST? [cardano-node-wiki/docs/getting-started/install.md at main · input-output-hk/cardano-node-wiki · GitHub](https://github.com/input-output-hk/cardano-node-wiki/blob/main/docs/getting-started/install.md#installing-blst)

---

<div class="post-metadata">

**Author:** ![fenix](https://avatars.discourse-cdn.com/v4/letter/f/eb9ed0/32.png) [@fenix](https://forum.cardano.org/u/fenix)\
**Post date:** [15 December 2023 10:46 UTC](https://forum.cardano.org/t/issue-with-8-7-2-upgrade-cabal-could-not-resolve-dependencies/125289/3 "2023-12-15T10:46:42Z")

</div>

thank you!  
finally it’s work

---

<div class="post-metadata">

**Author:** ![santiagopim](https://sea1.discourse-cdn.com/flex023/user_avatar/forum.cardano.org/santiagopim/32/58705_2.png) [@santiagopim](https://forum.cardano.org/u/santiagopim)\
**Post date:** [3 January 2024 22:18 UTC](https://forum.cardano.org/t/issue-with-8-7-2-upgrade-cabal-could-not-resolve-dependencies/125289/4 "2024-01-03T22:18:36Z")

</div>

The [Installing cardano-node and cardano-cli from source | Cardano Developer Portal](https://developers.cardano.org/docs/get-started/installing-cardano-node) documentation should be updated, actually does not mentions BLST.
