No inbound/outbound connects on my testnest relay node

Just began to start messing with a relay on testnet. It looks like my relay is synced up based on the fact that gLiveView is showing me on the latest Epoch/block when checking explorer.cardano-testnet.iohkdev.io. I tried adding a couple peers in my testnet-topology.json but I don’t see any connected.

The node is spitting out errors that look like this: [es-:cardano.node.DnsSubscription:Warning:59] [2021-02-10 03:41:46.19 UTC] Domain: “relays.cardano-testnet.uniquestaking.com” Failed to start all required subscriptions.

I can telnet to relays.cardano-testnet.uniquestaking.com on port 3001 successfully so I know it’s not my firewall. I also have traffic allowed to reach me at port 3001 which is the correct port.

For the peers to work manually like this, does the other end of the peer need to manually have me in their topology file too?

Hi!
No, the relays which you are connecting to do not need to include you in their typology.
If you synced up initially at least the connection to the reference server worked.
So I also would assume that there is no firewall issue on your side.
Maybe DNS, but then your telnet would also fail…
Have you tried other Testnet Relays already?

This link may help you to find other Relays to connect to:
https://explorer.cardano-testnet.iohkdev.io/relays/topology.json

It is shared in the Stakepool School here:
https://cardano-foundation.gitbook.io/stake-pool-course/stake-pool-guide/stake-pool/core_relay

And here is what gLiveView peer section shows:glive-2-10-2021

I have just configured a pool and it´s apparently working well but I don´t understand about the relays into topology.json. Do I need to insert manually relays or it will all work well only pointing to relays-new.cardano-mainnet.iohk.io and my BP ?
Where can I find a updated list of relays to link in case?

Many thanks

The is a tool called Typology Updater helping to automate this:
https://cardano-community.github.io/guild-operators/#/Scripts/topologyupdater

Hmm, Have no idea at the moment what might go wrong here.
Have you tried it with different other Servers as well? The error sounds like it was multiple times in the typology, but I don’t think that this would lead to no connectivity in the end.

zwirny, Will that topology updater work with the testnet? I’m currently taking the SPO course and I am also not connecting to any peers

I think I read in some other Thread that the Updater is also providing Mainnet servers. Not have tried this my self so cannot say for sure.

GLiveview and env asked me to update which I did and now I can see my peers!

This is how I fixed my issues, hopefully it can help. I am on testnet and now I can see my outbound peers. Not sure if this affects gLiveview like it does simpleLiveview, but make sure you have TraceBlockFetchDecisions in your config file set to true. Separately, Re-run your gLiveView and env files and it should ask you to update. I didn’t have cncli installed and it was using a fallback method to run the peer connectivity tests and it looks like that got updated.