Question 1.26.1 (node is syncing) (socket is missing)

What do you make of this? Its only showing 1 peer, even though it has both listed. and 2 are unreachable.

save 1 save 2

Did u also modified the producer topology file with the new private IP? I see only 1 OUT peer
Also try to restart the producer

For unreachable info press info [I] in glive

1 Like

Yes I just restarted block its good now, forgot this step.

image
image

1 Like

Do you know why I have more peers on my Relay 2 (19) Relay 1 (15)

Also its showing unreachable again:

image

IN or OUT?

I told u, unreachable is not an issue, all my relays are unreachable because I filtered the ICMP and is fine… unreachable not meaning is not ok

image

Block

Relay 2

image

Relay 1

image

My block is showing unreachable again on the peers.

image

That’s because ur nodes probably are trying to connect to different nodes from different areas… if u will want more OUT peers then u have 2 options:

  • increase the default number (15) for MAX peers in topology updater
  • add more custom peers ( add another trustable peers which u can find on adapools.org)
1 Like

Okay thanks for the tip. What about the unreachable problem on my block?

Did u presed info [I] in glive and read why u see and what means that message?
And I answered above to this question… mine are also unreachable because I filtered the ICMP ; unreachable not meaning bad

1 Like

Oh yeah I forgot thanks!

Hi @Alexd1985 wondering where I can find the path to cardano socket. What is the name of the file I am searching for ?

/opt/cardano/cnode/sockets$ ls -l
total 0

but as u can see while is syncing you will not have the socket file created… the socket will appear after the node will start

I am also in the process to update right now :slight_smile:

Cheers,

does that change if I build cardano with nix on a macos platform? the node is running but I cant find that folder

ok, sudo systemctl status cardano-node

then check the path to the socket … (u can use right arrow from keyboard)
in my case it’s showing
–socket-path /opt/cardano/cnode/sockets/node0.socket

Ok for some reason my find command was screwed. In the cardano-node folder I ran find . | grep socket and got ./state-node-mainnet/node.socket

I think for now problem solved. Thanks!

1 Like

u can also check the node startup script and inside you should be able to see the path for the socket file

my socket path is

/home/username/cardano-my-node/db/socket

i use coin cashew guide