Restarting node crashes halfwayway through validating chunks

Hi, sorry I have no idea what I am doing, but started up a node v1.29 ages back to try the lobster challenge and it worked then. Later I upgraded it to v1.30 and that worked.

Now I’ve coped down the new node binaries for v1.33 and slotted them in place, but…

When I start the node it validates slowly until about 20% of the way then really speeds up but at about 49% of the way through whatever it had stored it gets an error about unexpected failure and FSstring = “IO error” like this:

Sorry I’ve read everything I could find but don’t know what to do. Should I delete all the block history and start again?

Thanks for any assistance!

Is the disk full? That could cause this kind of error.

  • check the disk soace
  • check the RAM (free -m)
  • download the new files


If still not working compile again the node

Hi, thanks for the help!

The disk has heaps of space. Some snap folders are full but I think that is OK

Also has sufficient RAM (using 2.2 of 12GB).

I download the config files as per above but not luck - still fails at same point.

Could there be any parameters that have changed since 1.30 that I’m missing?
My startup command is:

The env variable for node is still set the same:

I didn’t compile the node - just downloaded the binaries.


try to compile the node, perhaps for 1.33.0 you will need more than copy the bin files

Ok thanks will give that a go