Script for cardano-node software upgrade (CNTOOLS users)

Hi Alex, thanks for the great script. I could use it to upgrade from 1.31 to 1.32 but it didn’t work for 1.33. I got the following message:


and cardano-node --version still shows 1.32 instead of 1.33
Any help is appreciated!

Try before to start the upgrade

cd  ~/tmp
./prereqs.sh

the tmp folder doesn’t contain prereqs.sh

then are u sure u are using cntools? Perhaps coincashew guide?

yes I am sure.

Ok, then

Check this solution

1 Like

Worked great again, thanks Alex

1 Like

image|827x

1 Like

first wget command is missing .sh at the end.

2 Likes

quite like this dialog screen, wasn’t familiar with it

1 Like

I just found out 1.34 was released… My node is running 1.32, does that mean I was not able to produce a block?

How do I know if an update is required or just suggested?

How can I get reliable notifications of updates?

I don’t think 1.34 was mandatory … did u had missed blocks?

Cheers,

Thanks Again Alex… no missed blocks quite a few missed slot leader checks %.15

I just ran the script for 1.34

and I see this

cardano-node --version
cardano-node 1.32.1 - linux-x86_64 - ghc-8.10

check if u still have the old binari files

cd /usr/local/bin
ls -l

bin$ ls -l
total 0

I just tried the other identical relay and had no issues

whereis cardano-node and which cardano-node can tell you, where in your path versions of cardano-node are installed and which of them is executed.

There has to be an old one in the path, before the updated one.

Hey Alex, how are you?

For some time now, one of my Relays has stopped syncing and just keeps the message:

(Standard_in) 1: syntax error: 36 remaining

My relay has the same hardware settings as another relay, which is working correctly.
7GB RAM + 5GB SWAP

I tested a few things, like copying the db folder from another relay. In the end, I ended up formatting the server in the account and configured everything from scratch, but it still has the same message.

Node Version: 1.34.1

Screenshot_1

perhaps the port inside env is different than the port used to start the node?