Script for cardano-node software upgrade (CNTOOLS users)

check if u still have the old binari files

cd /usr/local/bin
ls -l

bin$ ls -l
total 0

I just tried the other identical relay and had no issues

whereis cardano-node and which cardano-node can tell you, where in your path versions of cardano-node are installed and which of them is executed.

There has to be an old one in the path, before the updated one.

Hey Alex, how are you?

For some time now, one of my Relays has stopped syncing and just keeps the message:

(Standard_in) 1: syntax error: 36 remaining

My relay has the same hardware settings as another relay, which is working correctly.
7GB RAM + 5GB SWAP

I tested a few things, like copying the db folder from another relay. In the end, I ended up formatting the server in the account and configured everything from scratch, but it still has the same message.

Node Version: 1.34.1

Screenshot_1

perhaps the port inside env is different than the port used to start the node?

I left the default port (6000)… but there is one thing I hadn’t noticed, in relay3 I left 7GB RAM + 10GB SWAP.

In this Relay2 I was crashing, I had 7GB RAM + 5GB SWAP.

Now I’ve increased it to 10GB SWAP and it seems to sync again, a little slow, but it’s back…

If it works, I’ll post the feedback here for other people who have the same problem.

thank you for now.

image

hi, tried updating using the latest script to 1.35.0, got this error.

image

from here;

image

1 Like

Yeah, for 1.35.0 few more aditional steps are required before to run the script… I will take a look when I will be home

2 Likes

I see the scripts were updated for Vasil HF, should be fine now running the script (still not home for test)

Before to run the script prereqs must be run again

cd ~/tmp
./prereqs.sh

UPADTE:
only the scripts for alpha branche (tests) were updated right now… wait more time till the team will update also the master branche scripts… if u want to test it the run manually the script

cd ~/tmp
# delete old script/file
rm prereqs.sh

# download the latest script/file
wget https://raw.githubusercontent.com/cardano-community/guild-operators/alpha/scripts/cnode-helper-scripts/prereqs.sh

# change permission
chmod 750 prereqs.sh

# type no for updates when u run the script
./prereqs.sh
2 Likes

This script was not working for me until I added wget to line 50:

Also:
I am using this script to downgrade to 1.34.1 If anyone else needs to downgrade here is a change that will enable that on line 70.

you will just need to replace the url with : https://github.com/input-output-hk/cardano-node/tags?after=backport-2b1d18c

1 Like

Thanks for ur feedback, I added wget… the script was prepared for 1.35.x but the software version was aborded for the moment

:beers:

1 Like

Hey @Alexd1985 ,

I know the thread is about version 1.35 but I’m in need of a little help if you can…

My node is still at version 1.34.1 and I’m trying to transfer ADA to another address through cntools, and the error below is occurring. To withdraw the rewards also occurs the same error. Any suggestion?

Could it be because my node is not on the most current version or could it be because I have too many small transactions received in the same wallet?

If I can’t transfer through cntools, could I import into a wallet like Daedalus, for example, and execute the transactions??

NOTE: Since I set up my node + pool on this server, I have never tried to send ADA to another address.

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (MaxTxSizeUTxO 34500 16384)))])

tks

Transaction is too large (in bytes), which might well be because of too many inputs if there are really a lot of them.

Other possibilities are native tokens or metadata, but since you are transferring from a pool node that’s probably not it.

You should break that up into two transactions with roughly half of the inputs each.

Thanks for the feedback.

I tried sending a 2 ADA transaction to another address, and I also tried withdrawing the rewards from the wallet, all through the automatic cntools process. In both cases this error occurred. The way you said, would I have to do it manually then, ie outside of cntools??

Probably.

Import to a wallet app would only be possible if it is a seed phrase or a hardware wallet. (I would not use Daedalus, but Eternl or Typhon in that case.)

Otherwise, you have to construct the transaction manually by cardano-cli.

I got it. I will try, thank you very much.

I just remembered that this reward wallet I initially created at Daedalus and imported into cntools through the seeds. In this case, could I import into a wallet like Daedalus itself and send the transaction I need, or even withdraw my rewards?

If you have the seed phrase, sure, should be possible.

As said, I personally would not bother installing Daedalus and waiting for it to sync (or transferring the 80+ GiB of blockchain to it), but use one of the light wallet apps.

1 Like