Script for cardano-node software upgrade (CNTOOLS users)

I think… if u imported the wallet in cntools u imported only the 1st/oldest address of the wallet… if u don’t have funds on that address (check on cardanoscan.io) then u will have issues

Cheers,

I think I understand what you said, but let me confirm a few things:

In my rewards wallet “base.addr” file address contains a little more than 1k ADA

In the address of my “payment.addr” file of my rewards wallet, the values are zeroed

And in the stake address of my “reward.addr” file of my rewards wallet, there are the values of the rewards from my pool that I would like to withdraw.

What did you say would be the address that has zero balance (payment.addr) or to know the oldest address I would have to import the wallet into Daedalus again?

And if so, how could I solve this problem?

Inside daedalus just send 2ADA to payment address from cntools then check again in cntools if u see the 2 ADA and check again to withdraw the rewards

1 Like

The error message pretty clearly states that the problem is not missing funds on the payment address, but a transaction that is too large.

If you only used the wallet in CNTOOLS, the single-address vs. multi-address thing can’t be a problem.

If you want to continue using the wallet in a wallet app and CNTOOLS in parallel, use Eternl or Typhon and set them to single-address mode, so that they won’t use additional addresses beside the one recognised by CNTOOLS. If you don’t want to continue using CNTOOLS it does not matter at all.

1 Like

Is this working for 1.35.3 ?

Yes, was adapted… follow the steps

  1. download the script
  2. make it executable and run (steps above)
  3. Update Operating system (not mandatory)
  4. Update prereqs (yes)
  5. Update prereqs file from ALPHA branch (mandatory)
  6. choose **no** when/if it will ask to update again the prereqs (mandatory otherwhise it will be replaced with prereqs from master
  7. choose 1.35.3 version
  8. Wait for the new software to be compiled

image

Upgrade the nodes one by one, first time it will take more time to start (2-4 hours)

1 Like

I missed the screen shot it went by to fast but I captured a later one
image
Both relays are still showing their old version in glive.
image
One of my relays failed to update it the last time I tried, now both are going through the update but still show the old version.

did u downloded the latest software_upgrade script?
I just used it on 2 nodes without issues

1 Like

I used this command

wget https://raw.githubusercontent.com/Alexd1985/node_software_upgrade_script/main/software_upgrade.sh

I can try it again, I enabled putty logging.

check my picture… press no for SO update, yes for prereqs… then alpha and again no if it will ask

1 Like

not ok, delete the old software scripts… if u check the new script is renamed software_upgrade.sh.1

Saving to: ‘software_upgrade.sh.1’
2022-08-17 14:40:13 (70.5 MB/s) - ‘software_upgrade.sh.1’ saved [6126/6126]

delete all scripts older and download it again

and delete the comment above, u shared the server username… not recommended on a public chat

1 Like

I replaced the user and server name with generic information I thought. I deleted it just incase, thanks for the heads up.
The install is progressing now, I have no idea software_upgrade.sh.1 got in there?

If u had an older file caled software_upgrade.sh then the new file was renamed .1 not replaced

1 Like

Ah, I assume it would overwrite

Thanks!

1 Like

Worked perfectly after I fixed that. 4+ hours for of the relays and producer.

1 Like

I noticed you updated your script. What is the different between 1.35.3 and 1.35.3 configs?

I just ran the script on my relay node and selected 1.35.3-config.
gLiveView.sh shows this: Cardano Node - (Relay - Mainnet) : 1.36.0

What is 1.36.0? It’s not listed in the Releases.

are u sure u chose 1.35.3?
ahh u chose 1.35.3-config … please choose 1.35.3 only (is the latest version)

thanks. can I downgrade from 1.35.3-config to 1.35.3 using your script?