Script for cardano-node software upgrade (CNTOOLS users)

i tried to upgrade the second relay and clearly selected 1.35.3. it still upgraded to 1.36.0

i saw this:
Fetching origin

error: pathspec '1.35.3"' did not match any file(s) known to git
error: pathspec 'data-view-component="true"' did not match any file(s) known to git
error: pathspec 'class="Link--primary' did not match any file(s) known to git

Try manually

cd ~/git
cd cardano-node

git fetch --tags --all
git checkout 1.35.3

echo -e “package cardano-crypto-praos\n flags: -external-libsodium-vrf” > cabal.project.local
$CNODE_HOME/scripts/cabal-build-all.sh

That worked, thank you!

It looks like the memory requirement went up substantially. My 16G VMs will need an upgrade soon.

1 Like

Add SWAP file on each node

Hi Alex, I updated for 1.35.4 via your script (I choose the top line), but I see 1.36.0 [d15ff2b7] version after update, is it ok using this version on mainnet?

nope(1.35.4 is the latest official release), did u chose 1.35.4?

If yes probably the script is broken?

Try to upgrade it manually

cd ~/git/cardano-node

git fetch --tags --all
git checkout 1.35.4


echo -e "package cardano-crypto-praos\n  flags: -external-libsodium-vrf" > cabal.project.local
$CNODE_HOME/scripts/cabal-build-all.sh -o

Works great, thanks. 1.35.4 [ebc7be47]

1 Like

Master or alpha branch? I tried on 3 servers none upgraded. Trying again now.

I selected Master > 1.35.4

image

Went to 1.36.0

Hi, read what Alex wrote to me and just upgrade it manually.

Yeah, I will check the script when I will be home, till then u can modify the script or upgrade it manually

And use master branch

Manual command works after using script to download updates.

updated using the script.
but got version 1.36.0 even tho i selected master and 1.35.4

does say its on mainnet, but the github cardano latest
https://github.com/input-output-hk/cardano-node/releases/latest

says 1.35.4 as latest…
@Alexd1985
is this a bug or is the github just not up to date.?

i mean it wouldn’t be the first time the github is wrong…
surprisingly enough for a project the size of cardano.

let me update the script, working now

2 Likes

let me know when you update it, updating someone elses server for them.

tried a second time, still got 1.36.0
it gives me this when i select 1.35.4 during the install
image

the relay node starts up on mainnet and runs on 1.36.0

image
think ill just leave it for now and maybe try the manual upgrade path…
last time that went pretty smooth.

Sorry, I was to the summit without laptop… indeed there was an issue with the script… is fixed now

U must download again the script

Should work now; I tested on my relay
U must re-download the script

1 Like

i totally mistook the working now with the script working now…
you where working then, that explains why i got the same result twice :smiley:

trying again 3rd time’s the charm…
yep it worked getting the right version this time, thanks @Alexd1985

1 Like

Thank you,

Now working for update part (if a new version will be released on github then it should ask for update)

UPDATE: auto update check fixed;

(you will need to download the latest file)

2 Likes

been trying to update my BP node a few times using the script, but it always ends up being on the same version 1.35.3 not 1.35.4
i have downloaded the new script.

not sure if this is any help but i get this error message towards the end, not sure if there are any others.
any suggestions, or should i try manually updating it instead.?