[Solved] Slow sync after 80%

Hi my cardano node is slow to sync i have free ram and cpu and enough bandwidth

Every 2.0s: cardano-cli query tip --mainnet                                                                                                                                       cardano: Sun Oct 10 15:11:28 2021

    "epoch": 237,
    "hash": "d44fbcac93b052468c27321b5f378fd68ab98ac09ccca137bbcac8806541439e",
    "slot": 17374987,
    "block": 5124999,
    "era": "Allegra",
    "syncProgress": "80.47"

my config like topology and … updated with this script




NWMAGIC=$(jq -r .networkMagic < $GENESIS_JSON)

echo -n "Network Magic: ${NWMAGIC}\n"

blockNo=$(/home/cardano/.local/bin/cardano-cli query tip --mainnet | jq -r .block )

echo -n "Block NO: ${blockNo}\n"

wget -t 60 https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-config.json -O ./config/mainnet-config.json

wget -t 60 -b https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-byron-genesis.json -O ./config/mainnet-byron-genesis.json

wget -t 60 https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-shelley-genesis.json -O ./config/mainnet-shelley-genesis.json

wget -t 60 https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/mainnet-alonzo-genesis.json -O ./config/mainnet-alonzo-genesis.json

wget -t 60 https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/rest-config.json -O ./config/rest-config.json

curl -s -o ./config/mainnet-topology.json "https://api.clio.one/htopology/v1/fetch/?hostname=${NWMAGIC}&customPeers=${BLOCKPRODUCING_IP}:${BLOCKPRODUCING_PORT}:1|relays-new.cardano-mainnet.iohk.io:3001:2"
1 Like

you are not the only person with this problem,but i had it 2 ,before updates 4.0.0 to 4.3.1 it was ok my sync i think cardano node is getting very heavy on software because of nft smartcontracts erc etc and what is stil to come to cardano blockchain,what i do now i sync every day to stay above 99.90% of sync it helps me out for the time now😎

1 Like

why most be happend this issue my server have 16 gb real ram 12 gb swapp 6 core cpu and ssd hard and my topology file update every 1 H i cant understand this problem

also after one day my network growed to 95.25%

For how many hours is it syncing already? It’s expected to get slower, as with time there were more blocks produced. I guess the % is based on the slot number, so in the beginning it’s fast because there was not that much data.

Btw you can configure your node to use more than 2 cores (IIRC that’s the default). Search for “RTS -N” or see discussion here: How long does it take to sync a new cardano-node server running v1.29?

1 Like

that’s be amazing i added +RTS -N4 --disable-delayed-os-memory-return -I0.3 -Iw600 -A16m -F1.5 -H5500M -T -S -RTS parameters on my node runner script sync process is faster than IIRC

Important! This parameter customized with my OS hardware don’t just copy/paste
Guide for RTC

1 Like