Unknow Peers on Core Node with CNTOOLS

hello cardano community, we have a problem, on our core node we have 2 unknown incoming connections on gLiveView, does anyone know where they come from? we use cntools, in the topology file we have only set our relays

Screenshot 2023-01-31 165456

Is your own node… press p again… now u should see 3… and so on


the others already show too, found out that if i disable cncli they are no longer shown. so the peers are from cncli, how can hide these peers on gLiveView without disabling cncli?

If u know scripting check inside gliveview script (nano gLiveView.sh)

Why do u run cncli on relays?

I looked at the gLiveView script, there are no settings to hide it.

Did i written something that i have cncli running on the relays?? I wrote on the core node (block producer).

I have see your also use cncli [CHRTY], if you want to help me take a look at your gLiveView block producer peer analysis and see if it shows the following, please.

Yes, I have these peers too… as u said its because cncli
did u try to play with these settings from glive?

#CNCLI_CONNECT_ONLY=false                 # By default cncli measure full connect handshake duration. If set to false, only connect is measured similar to other tools

yes I have tried, uses nothing

But u uncommented the lines right?

Can be related with this

latencyCNCLI () {
  if [[ -n ${CNCLI} && -f ${CNCLI} ]]; then
    checkPEER=$(${CNCLI} ping --host "${peerIP}" --port "${peerPORT}" --network-magic "${NWMAGIC}")
    if [[ $(jq -r .status <<< "${checkPEER}") = "ok" ]]; then
      [[ ${CNCLI_CONNECT_ONLY} = true ]] && peerRTT=$(jq -r .connectDurationMs <<< "${checkPEER}") || peerRTT=$(jq -r .durationMs <<< "${checkPEER}")
    else # cncli ping failed

if u want to play make a copy of ur glive an edit it

Did u set like this?


yes, not works

and this one ?


anyway, can be filtered from glive script (there is a code insode for filtering/showing the IPs) but u must know scripting… I don’t so… I can’t help you

I have tried all this already, does not work, it does not matter, maybe this setting will be built into the next version, thanks for your help