Update Cardano Node to 1.31.0 - for Coincashew users

please try the following command:

ps waux|grep cardano-node

Seems, that there’s still some process running. Btw, there is only one cardano-node process, i.e. you might have 2 binaries installed: the one the service is configured with and the other one in /usr/local/bin.

Yes, I have version 1.31.0 still in the file, and upgrading to 1.32.1… The file in the /bin folder is the older version.

erndawg 4384 2.5 13.9 1074582328 9162788 ? Sl Dec19 13:13 /usr/local/bin/cardano-node run --topology /opt/cardano/cnode/files/topology.json --config /home/erndawg/cardano-my-node/mainnet-config.json --database-path /opt/cardano/cnode/db --socket-path /home/erndawg/cardano-my-node/db/socket --port 6000 --host-addr
erndawg 1678397 0.0 0.0 17668 2580 pts/0 S+ 07:43 0:00 grep --color=auto cardano-nod

You see that you’ll still have the node process running; try killing it with

killall -s SIGKILL cardano

the you’ll be able to replace the binary.

That worked, had to run it twice… I think there was a scheduled back running.

Thank you very much for the help…


:+1: :slight_smile:

Great to hear!

Followed this same guide for 1.32.1 update. Zero issues. Smooth!

1 Like

Remember to update the permissions of the new Cardano-cli binaries that you place on your air gap, or else you will be unable to signoff on transactions or pool.cert changes.

I had to do the following:

Right clicked my “Cardano-cli” > Properties > permissions > check “allow executing file as a program”

One this was done, I was good to go again.

Used this guide to update to 1.32.1

For others wanting to do the same, you only need to change one line, the tags.


git checkout tags/1.31.0


git checkout tags/1.32.1

The rest remains unchanged.

Thankyou for sharing @DavidNC

1 Like

Excellent info, thanks for taking your time and sharing it, this helped me a lot, I used the same steps to update to 1.32.0 and 1.32.1 versions and worked in both times., just had to change the tag version in git checkout in step 2.

can anybody help with how to send ada from your stake wallet to external wallet after the new utxo update im continuing to get this same error. Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (FeeTooSmallUTxO (Coin 177337) (Coin 176765))))])

All my nodes are updated to 1.32.1 and my bp and relays are connected via glive showing in and outs are good. TICKER ( ADAWN) we’ve minted and have been overachieving almost every epoch please help this pool is my baby haha

Hi, for those wanting to update to 1.33.0 for coincashew, you’ll need to upgrade your ghc to 8.10.7 (refer to 1.33.0 build instructions cardano-node/install.md at master · input-output-hk/cardano-node · GitHub)

ghcup upgrade
ghcup install ghc 8.10.7
ghcup set ghc 8.10.7
cabal update

Don’t forget to checkout the right tag

cd $HOME/git
git clone https://github.com/input-output-hk/cardano-node.git cardano-node2
cd cardano-node2/
git fetch --all --recurse-submodules --tags
git checkout tags/1.33.0

And use 8.10.7 in the build

cd $HOME/git/cardano-node2
cabal configure -O0 -w ghc-8.10.7
echo -e "package cardano-crypto-praos\n flags: -external-libsodium-vrf" > cabal.project.local
cabal build cardano-node cardano-cli

The rest of the steps are the same. It takes a few hours by the sounds of it for 1.33.0 to work through the ledger on startup, so be ready (and patient) for that.


Hi jeremyisme. I tried using your method and it results in the error log below when i run the last command of cabal build cardano-node cardano-cli. Do you have any issues like mine? Thanks

By the way, i am currently on 1.32.1 and i have confirmed that my cabal version is and ghc is 8.10.7

cabal: Failed to build exe:alex from alex-3.2.6 (which is required by
test:cardano-node-test from cardano-node-1.33.0, exe:cardano-node from
cardano-node-1.33.0 and others). The failure occurred during the configure
step. The build process terminated with exit code -6
Failed to build base-compat-0.11.2 (which is required by test:cardano-cli-test
from cardano-cli-1.33.0, test:cardano-node-test from cardano-node-1.33.0 and
others). The failure occurred during the configure step. The build process
terminated with exit code -6

I didn’t see any error like that. Did you follow all of the instructions at the start of this thread? You still need to do all the normal steps listed there.

Yup, I tried recompiling 1.32.1 and it was fine. I moved on to 1.33 and the issue happened. Other than the listed error log, there are also cases that it mentioned resources exhausted. I tried stopping the node and some issues were not shown. I guess I have to do some swap

I’m having a little trouble with my BP at the moment after my build. It isn’t talking to my relay anymore…hold off if you don’t need to upgrade I suggest. Hopefully it is just me.

Check if the cnode port from env file matching the starting port

yep, both still the same on relay and BP…

Did you see my other post, I have a couple of errors listed.

hi all, i resolve the issue that i faced. The swap that i added did not helped. What i believe happened was that probably my OS met with resources constraints as the cabal build was spawning too many threads that my system cant handle. For this case what i did was to exe the cabal build sequentially with only 1 job

cababl build -j1 cardano-node cardano-cli

Hope this help someone!

1 Like