Updated BP to 1.33.0; socket path error when attempting to pull balance and showing 0 served

Hey everyone. I updated my block producer today by pulling all files and the cli’s to a new SSD, then rebuilding the node from there. I then replaced my old BP’s SSD (which was on 1.31.0) with the SSD updated with 1.33.0. Below is the gliveview output:

My pool has produced 1 block, which showed up on the original copy of the BP as shown below:

So that’s my first concern, the new BP copy shows no blocks served. Is this cause for concern?

My 2nd issue is that I am unable to pull my pledge balance. When I type in the command to do so I get a socket path error.

I have the old copy of the BP ready to boot if I need to. Hoping I can troubleshoot these issues though so I can stay on the updated version


for the socket error u will need to export the path

echo export CARDANO_NODE_SOCKET_PATH="$NODE_HOME/db/socket" >> $HOME/.bashrc
source $HOME/.bashrc

now for the BP output
should not be any problems if u don’t see 1 served anymore (if u reboot the old server/machine do u still see 1 served?)

I don’t know if it will work but u can try to run
./cncli.sh sync
./cncli.sh init

1 Like

This did the trick, thanks Alex!

Do you think the missing “served” block is cause for concern?

For sure not

1 Like

You’re the greatest Alex!! Really appreciate all you do :+1:

Thanks, did u tried?

No such file or directory.

Same effect when trying:

Find cncli.sh

Perhaps something in the bin I failed to copy over from my prior SSD?

Nope, nothing to do… did u rebooted the old server? I think this information is lost when the server/machine is rebooted

anyway… the BP is fine, nothing to worry

1 Like

I have not tried rebooting the old SSD yet. I’ll update this thread if I end up getting curious and doing so…

Thank you again for you help. If you ever visit America let me know, I owe you a beer!! :beers:

1 Like