Usage Errors Creating Stake Pool With Scripts and Jormungandr RC7 R7

I was originally trying to resolve this on Telegram, but haven’t been able to post any of the groups. Here is a synopsis of my current issues when trying to set up my stake pool:

I’m getting the following errors when I execute the (./ 3100 <PRIVATE_KEY_SK> script from here: github -> /input-output-hk/shelley-testnet/tree/master/scripts.
Error 1:
failed to make a REST request
|-> node rejected request because of invalid parameters
|-> Client Error: 404 Not Found
Error 2:
error: Invalid value for '–account-spending-counter ': cannot parse integer from empty string
Notes: I used the createAddress script from the same source to create the address and keys. I’m currently using Jormungandr version: ./jormungandr --full-version jormungandr 0.7.0 (HEAD-a93d4f6, release, linux [x86_64]) - [rustc 1.39.0 (4560ea788 2019-11-04)]

@Linicks You are using a stilled version of the script. The current script you’re running still contains lines to sign the stake pool registration cert. The latest updated version for rc7 does not require an SK to sign the cert. The solution: download the newest version of the script from the following link

@DAPP360_MIKE Sorry, just read this after typing my response in the other thread :slight_smile: I’ll try these scripts and report back…

No problem. Keep me posted.

@DAPP360_MIKE Ok, I just tried it with the scripts mentioned above, and I continue to see the errors:

failed to make a REST request
|-> node rejected request because of invalid parameters
|-> Client Error: 404 Not Found

error: Invalid value for '–account-spending-counter ': cannot parse integer from empty string

I can get stats from the rest end point though:

jcli rest v0 node stats get --host “

blockRecvCnt: 580
lastBlockDate: “30.292”
lastBlockFees: 2200
lastBlockHash: f884d015f96f30954f1a56738475fdc45aa04886536ed82867885daa6f6f3200
lastBlockHeight: “20740”
lastBlockSum: 2674002200
lastBlockTime: “2019-11-12T22:51:30+00:00”
lastBlockTx: 2
state: Running
txRecvCnt: 104
uptime: 1276

$ date
Tue Nov 12 22:52:32 UTC 2019

You tried to register your stake pool but you account does not have faucet funding. You are close. Make sure you create an faucet funding address using the link below and then run the curl script

After, you need to run the curl script from your terminal

curl -X POST

Give it some time for your transaction and your address to register on the testnet blockchain. Then rerun your createStakepool script once you got some faucet funds in your account

I am about to head out but here is a reference step-by-step guide from IOHK

@DAPP360_MIKE I’m still having issues accessing the account endpoint on my node. I was able to successfully get Ada from the faucet with the curl command mentioned above, but the account info still isn’t accessible on my node.

Ada Request

curl -X POST


Node Error

After waiting several hours and verifying that my node is in sync, I’m still getting this error:

$jcli rest v0 account get --host
failed to make a REST request
|-> node rejected request because of invalid parameters
|-> Client Error: 404 Not Found

Your guidance is appreciated!

@Linicks That error simply means your account could not be found on the testnet blockchain at the time. If it were you would have seen an account balance. Even though the funding transaction was successful, it seems like it was not added to a block that was written to the blockchain. I would run the curl command again and check the explorer after a while.
Also an ambassador was asking for your Telegram account handle. Did you give it to him? Because the best way to resolve your issue is to dig through the Stake Pool Best Practices Tg channel.
Here’s the post to provide your TG handle

@DAPP360_MIKE That makes sense, but it seems like all my requests aren’t being populated to the blockchain. I’ve done this process repeatedly since 7rc3, and I never seem to get funding to the test address that I’ve created. I tried the curl command a couple of times today, and it gave me a “No funds available in faucet account”, but I went to the Shelley test net faucet ( : ) and it gave me some Ada:

Your request has been processed successfully by the faucet and 10000 ADA has been sent to ca1s5k9nxacw0p2r5jkqv26e2yy3rhkaxypzrffupjdvwxqvsf2mcuzcdmmh0v. Remember that you will incur 0.0011 ADA transaction processing fees on the testnet.

Please verify the following transaction hash:


I’ve tried to search the Jormungandr Explorer for the transaction hash(s), but always get an error. I did follow up on getting back onto Telegram here (How do you contact the Cardano Telegram Admins?). Essentially, I created a new TG account, but I have to wait until the grace period is over before I can post. Also, this forum has very low limits to the number of posts and replies that I can have. So I wasn’t even able to communicate with them until that waiting period was over for my first round of use. I do appreciate your help trying to troubleshoot this, but certainly have been a number of bumps alone the way thus far :slight_smile:

My advice to you is to test using the latest V0.7 release. Some of the tools for rc3, rc4, etc are nightly build. So they might introduce breaking changes or be inactive. The latest release is where the action is.

This is best handled on the workgroup, as troubleshooting here will be incomplete . Thanks for helping him out :raised_hands:
Also, 0.7.0 is not compatible with rc7 - and should not be used unless updated information is made public (exceptions ofcourse - if you’re an advanced user and know how the updates affect you). Also, the user is now in Stakepool workgroup - looking back at his messages across multiple posts, there is not a clear information about genesis, config, (recent log showed he was on 0.7.0 - invalid), and whether the corresponding faucet / explorer are being used.