Wallet synch problems after it used to work fine - RC found for me


#1

Hi,

I just recently experienced a weird thing. Like many others on this forum after using the daedelus wallet just fine. Today i encountered for the first time my wallet just “connecting to network”.

Having not tried remove stuff or restarting PC. For me the trick to get it working was kinda weird.
I just closed my running browser !?!?

I run the new mozilla firefox Quantum on my Win10 pro.
But i have a feeling some of the addons i use in my browser for security, privacy and ease of use while browsing might actually work against the wallet trying to connect to the network.
I first researched my firewall/antivirus which is Bitdefender Total Security 2018 and i saw that the cardano node had an IP in the range of 169.xxx.xxx.xxx.
This normally occurs when Windows does get an IP from a DHCP server then it shoud allocate itself an IP in the same range. that process is called APIPA in windows. My internet was working fine all a long. It was not my connection.

By closing my browser while Daedelus trying to connect to the network, it actually connected. After reopening my browser while having the wallet open, my whole screen flashed, wallet background went black and then back to normal. I heard my laptop fans blowing air more than usual which indicates that there is something going on. Syncing was not the case as it was already 100% synched. I guessed Daedelus could not access the internet.

If the Dev want to reproduce my weird experience. i use Firefox Quantum 57.0.4 (64-bit) with enclosed addons in my browser.

I could not upload a second screenshot, so the rest of the list:

  • popup blocker (strict)
  • Privacy Badger
  • Privacy Settings
  • Request Control
  • Search Image
  • Search Preview
  • Self- Destroying cookies
  • Similar Sites - Dicover Related Websites
  • Simple URL Extender
  • Skip Redirect
  • Snap Links
  • SoundCloud Control
  • Traffic Light
  • uBlock Origin
  • uBO-Scope