Yoroi Ledger Wallet not connecting to Nano S for confirmations

I have had my Yoroi Ledger wallet for a while now and staked through it to 3x different Pools already. I wanted to register for Vote Fund 5 and then I battled to get confirmation via the emurgo connection - thought it was just on Yoroi backend side. Tried again to register for voting on Fund 6 - same issue does not connect to Nano s through emurgo - then tried to withdraw stake in order to move my funds to a normal wallet - still no joy. Itried through adalite - also no joy ???
What am I to do ? I need to withdraw from staking and am unable to do so !

Not sure what you mean.

What are you trying to achieve exactly?

Trying to withdraw my stake at present - but everytime I try all I get is a black block saying that “emurgo.github.io wants to connect to a HID device”
Nano S is connected via USB and the Cardano app on it is open - just not connecting

You have to select your “Nano S” and then click on connect. :slight_smile:

It already says Nano s - just does not connect at all!

Click on “Nano S” and then connect :slight_smile:

I now feel stupid - Thanx

haha you dont have to do so. There are actually alot of peoples with the same issue :slight_smile:

Working like magic