Yoroi wallet won't connect back to my ledger (It has worked in the past)

I’m trying to enact transfers and claim staking rewards with my yoroi wallet. This wallet is connected to a ledger nano s. I’ve been able to do these actions without issue in the past but keep getting an error now.

This is the error I’m getting:

It is paired:

Ledger live has been updated and the ledger will connect easily to ledger live.

Which browser do you use? You might want to test it out with a different browser.

Also make sure the Cardano app on your Ledger is updated.

The firmware on the ledger is up to date 2.0.0

The Cardano app is version 2.4.1

I’ve been using Chrome.

I just installed the plug in with firefox and was able to load my ledger wallet and view it on the firefox plug in… so that was encouraging since it was accepting prompts from my ledger.

However, once again, when trying to send ADA or Withdrawal and Deregister from staking I get the same error.

Hm yeah thats strange…

Could you please try to connect your Ledger device via adalite.io and make the transaction there to test if that works?

Yep, just connected and it worked fine on adalite

Since my goal was to transfer the ADA off this wallet onto a trezor wallet… adalite will solve my issue. Thank you Zyroxa

1 Like