Any experience with Ubuntu 22.04 LTS?

My servers are prompting me to upgrade, and typically I feel that new versions are a good idea to go to from both a stability and security standpoint. Also, typically Ubuntu upgrades should be fairly straightforward, but I don’t know as to how it applies to Stake Pool Operation. Any input?

I run Debian but Ubuntu is based off it. I regularly do:

apt update
apt dist-upgrade

If you want to build deb packages for cardano-node take a look at the repository I put up which has the necessary debian/rules, control and other config files for building it as a deb.

1 Like

I see the prompt on my servers too but I haven’t upgraded yet. I don’t think there is any hurry to upgrade to 22.04.

Ubuntu 21.10 is no longer supported because it wasn’t a LTS release. And 21.04 is really really old. So, IMO, yes 22.04 is a serious option for running a safe pool service.

21.04 also was not LTS. They come only every two years. 20.04 was the last one and will be supported for quite some time.

My server (not running a pool, just some web and mail) is still on 18.04, though. Need to update later this year.

But all LTS releases back to 14.04 still get security updates. So, it should not be a security issue, at the most a dependency issue.

1 Like

I’m not so much a fan of back-porting stuff to such old distros. Even back-porting security fixes can cause new security issues. Had no problems since the Upgrade to 22.04LTS. Only the libssl stuff is a bit annoying. But - as described - easily fixable.

1 Like

Thanks, @Terminada - but what do you mean by “build deb packages for cardano-node” - do you mean build a cnode VM like Docker? No, I have a cnode running, and I wondered about upgrading Ubuntu - but that is going back to 2019 or earlier for anyone running a Cardano node on that, unless they upgraded Ubuntu to a non-LTS release, or if maybe they upgraded it running on another distro…

I’m thinking maybe I take a snapshot, do the upgrade, and see what issues I run into - can always revert. That way, I can report back as to how well Cardano-Node responds to an OS upgrade (at least in Ubuntu’s case). Just curious, how many people are running non-Ubuntu Linux for C-Node?

I don’t run Ubuntu but have run Debian for 20+ years. Upgrading is easy and reliable. I just edit my sources list (/etc/apt/sources.list) and change to the new stable. Then simply:

apt update
apt dist-upgrade

I understand that Ubuntu is the same since it was based off Debian.

As for the Deb package for cardano-node: Building the cardano software as a deb package just enables the package manager to take care of upgrading your cardano software too. Just like all your other software on your Ubuntu system. Apt is a great tool and is the primary reason I have always run Debian since before Ubuntu existed.

There is usually many ways you can install a piece of software. Maybe it is just me, but I always choose the deb package method because it offloads future security updates and upgrade headaches to the apt package manager, AND, it puts everything in the standard filesystem locations so PATH and LD_LIBRARY variables don’t need to be modified.

running 22.04 LTS & 1.35.3 smoothly
upgraded inplace from 21.04

1 Like

Also running 22.04 LTS smoothly.

1 Like

Anyone having issues upgrading to 1.35.4 on Ubuntu 22.04? I’ve only successfully compiled on my machine running 20.04.

Keep getting:
collect2: error: ld returned 1 exit status
'gcc' failed in phase 'Linker'. (Exit code: 1)

Other errors include:
error: undefined reference to 'SSL_get_peer_certificate'
error: undefined reference to 'EVP_MD_size'
EVP has other errors referencing CIPHER and PKEY.

Have checked paths and followed official documentation. That’s where I saw supported Ubuntu was 20.04 and led me here. Thanks.

I had the same problem. The issue here is, that Ubuntu 22.04 is using libssl version 3 while cardano still works only with libssl version 1.1.1.

A short description to install libssl version 1.1.1 on Ubuntu is here: How to build 1.35.0 from source on Ubuntu 22.04

1 Like

Thanks, I’ll give this another shot, glad to know it does work. Maybe still referencing libssl 3.

The important part here is the dev package as it gets updated to libssl3-dev with every automatic upgrade.