Cardano Native Token error

Hi there,
I am playing with cardano Multi-Asset Tokens and Im tring to create a token. When i ran started the cardano node using launchpad files from this Working with Multi-Asset Tokens
i am getting this kind of error :
[adarelay:cardano.node.ErrorPolicy:Warning:51] [2021-03-13 19:59:02.06 UTC] IP ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace DecoderFailure (BlockFetchHardForkBlock (’: * ByronBlock (’: * (ShelleyBlock (ShelleyEra StandardCrypto)) (’: * (ShelleyBlock (ShelleyMAEra ‘Allegra StandardCrypto)) (’: * (ShelleyBlock (ShelleyMAEra ‘Mary StandardCrypto)) (’ *)))))) ServerAgency TokStreaming) (DeserialiseFailure 2049 “An error occured while decoding asset name exceeds 32 bytes:.\nError: loooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000g”))) 200s 200s
[adarelay:cardano.node.DnsSubscription:Debug:55] [2021-03-13 19:59:02.21 UTC] Domain: “” Restarting Subscription after 2.266667428s desired valency 2 current valency 0
[adarelay:cardano.node.DnsSubscription:Debug:55] [2021-03-13 19:59:09.94 UTC] Domain: “” Starting Subscription Worker, valency 2
I have funded my node using the faucet but there is still no fund on my address.

1 Like

It seems like that guide refers to an old version (1.24.2) start with downloading the newer version of 1.25.1.
If you need some help to get started on that you have a more up-to-date guide here: Guide: How to build a Cardano Stake Pool - CoinCashew :slight_smile:

It is kinda weird, i am running version 1.25.1 also i downloaded those launchpad files from the site.

Here I’m in the exact same situation with the same problem as OP. Same error message in the log, funds not arriving. Only difference is that I’m using 1.26.0.

I don’t know if those “launchpad” config files on that page are the same as is used now for testnet. I would suggest that you try the updated documentation just for configuring and starting the node (Guide: How to build a Cardano Stake Pool - CoinCashew)
without the staking and address parts and see if it works better!

the name of the token is wrong. Please give a shorter name…
Using launchpad config is ok - since that is the testnet/playground for multi assets. If you would use mainnet config then the token would be created on the mainnet.

I’ve found that you can use Daedalus as your local node as it is in fact a fully working node. Just look for the socket file in the program directory and configure your CLI as described in the guide.

1 Like