Cardano-node 1.25.1 released

Hi everybody,

IOHK just released cardano-node 1.25.1. It says on GitHub this update is mandatory for the transition to Mary era.

Any opinions on wether I should update my SP-node immediately or wait a bit? Also are there any other actions to take for the upcoming fork?


You have all the informations here



Any upgrade guides available?

i believe is a normal upgrade process…
you just choose the proper version


yes, the 1.25.1 is the current latest release for mainnet - so you can update it.

if you are using controls, then wait for official controls release for 1.25.1 as there are some changes.

if you manage the pool manually or with scripts (e.g. Martins scripts), then you can follow this guide: Upgrade to 1.25.1 - Cardano Node Installation and Configuration Guide


Did upgrade, worked as expected. Thanks

Did anybody else have problems with the topologyUpdater script? After the update I am getting:
{ “resultcode”: “503”, “datetime”:“2021-01-29 20:14:01”, “clientIp”: “”, “msg”: “blockNo 5274120 seems out of sync. please retry” }

Is this an issue? Will my relay be deleted from the topology?

Wait till ur node will be sync and then try again.
don’t worry, other nodes are already connected to your node… so will not be a problem if i are not running topology updater for a short time

Thanks for your answer, but I am actually sure that it is synced. gLiveView shows it to be synced and my tip badge on is up to date (even with one relay). Or what do you mean with sync?
Seems to be odd and I dont want to rebuild my db for sure :wink:

Ok, and if u are running the topology updater now, u are receiving the same error?

exactly, same:
{ “resultcode”: “503”, “datetime”:“2021-01-29 20:50:43”, “clientIp”: “”, “msg”: “blockNo 5274225 seems out of sync. please retry” }

This is ur relay right?
How is it your topologyupdater script? Nano topologyupdater … is it right?
How is it your topology file… nano topology.json is it right?


yes, thats my relay. The script worked with 1.24.2 as well as the topology file. And I’havent touched them since…

I know, I had few issues with the scripts today but not with topologyupdater. Are u using cntools?

I don’t use cntools for setting up or updating the pool. But the topologyUpdater script and gLiveView and relay-topology-pull.

I will try clearing the db and sync from scratch…

I don’t know what can be the reasson… check ur configuration file… if it has

“TraceBlockFetchDecisions”: true,

Thought of this as well and I actually forgot to set it up after downlaoding the latest-buil version but it didn’t solve the issue.

Anyways thanks so far, I’ll let you knwo if a clean db solves the problem

Check this first

TraceBlockFetchDecisions”: true,

Also check this update guide here

!!! IMPORTANT . This update code is for the nodes/relays that were setup following CoinCashew guide .

Hi there - is there an upgrade guide for cntools yet?

hmm, nope, I upgraded my nodes with few issues, I will say u to wait more days before to upgrade