Cardano node run not working

Hello people,

I have a problem running the testnet on my pc…

I run the cardano node with:

cardano-node run \
--config $HOME/cardano/testnet/config.json \
--database-path $HOME/cardano/testnet/db/ \
--socket-path $HOME/cardano/testnet/db/node.socket \
\--port 1337 \
--topology $HOME/cardano/testnet/topology.json

And i get this output..

 Can you tell me what to do so i can successfully run the cardano node? Thank you

Testnet is not valid anymore you want to use preprod check this article

i will check it and let you know, thank you!

finally i was able to run the cardano node and now i wanted to interact with it and i encounter a weird problem… In the new terminal where i have to execute cardano-cli commands it says cardano-cli: command not found… I am at the right place where the cardano node is installed… Than i tried to run cardano-node --version and it showed me the same that the command can not be found… I stopped the other terminal where the cardano node was running and tried to execute cardano-node --version and it showed me the version of the cardano node… What is the problem that the cardano-node and cardano-cli commands do not work in a new terminal window? Very weird…

You need to add cardano-cli to the path but you need to have some basic knowledge around unix systems and programming otherwise you will have hard time moving forward and building applications


i work as a cyber security engineer so it wont be a problem… maybe it is a little harder but i will figure it out… thank you

i managed to add the cardano-cli and node to the path needed… i can not understand why i had to add them twice but now it is ok… Also i do not want to open new thread and i will ask here… When i tap the network with the tap command i can see it creates a block but why i can not see it in the prepod cardano explorer? Also i can see that the the explorer skips some of the blocks, why is that?