Cncli leaderlog

Hi there,

The leader log schedule output of cncli doesn’t seem to show all assigned slots anymore?

It only outputs 2 slots, where my block producer already produced 4 blocks, all of which are not listed in the output of cncli.

Is this maybe related to the updates in cardano-node version 1.26.1 where the slot election process no longer leads to a peak in resource usage at a certain point in de epoch?

Whe u ran the cncli leaderlog?
Did u installed the last version?

I just ran it for the current epoch, version 2.0.2 and did a sync first in a new dir

1 Like

do you use the correct poo ID `?

Hmm; I have only 2 blocks assigned … I will tell u if I will make more… but I don’t think is the case

I have the same. Only 2 blocks assigned, but they are still to be minted. At this point I already minted 4 blocks in the current epoch, all not listed in the output

Off course the pool id and all other parameters are correct, like every other epoch where it ran just fine

1 Like

Then… I will tell u, for the moment not blocks minted

Hi Alex, it seemed the $PATH still contained the dir to the old version. New version fixed the problem!

1 Like

79% down the road of the current epoch, I’m trying to get the leader log from cncli version 2.1.1

It responds with message:

“status”: “error”,
“errorMessage”: “EOF while parsing a value at line 1 column 0”

Any idea?

I get that all the time… Usually just corrects itself eventually throughout the day. Unfortunately, I don’t know the case - just keep trying it.

Same for me, wait and try again latter

Update: updated cncli to 2.1.1 version and it worked

If u are using cntools

cd ~/tmp

./ -c


@mcvetyty @bjorn

hmmm. I’ve got CNCLI 2.1.1 and still having that parsing error. Guess I’ll wait till the AM and try again? Not using CNtools, but the cncli command has worked at this point in past epochs. Guess I’ll just try again in the morning. Let me know if anyone else finds an issue.

Still not working for the next epoch.

Current epoch is working fine.

Before it always worked for the next epoch when the current epoch was 70% underway.

Did something change on that regard?

Think I found the cause of this problem.

I’m running cncli relying on the output of<POOL_ID>/266 (as a result of not specifying the --ledger-state file)

This url gives an empty response, where a json format is expected.

Guess we just have to wait for this url to report the sigma calculated from the active stake for the next epoch per total staked.

Or we have to run the cardano-cli query ledger-state on the node

Exact same issue for me, it started happening the last epoch.

I’ve been using Andrew Westberg’s scripts does the ledger state query.
But I Still am getting parsing errors currently. Is yours working yet?

OK, it just worked correctly just now.
Guess sometimes things are updating a little slower than the standard 1.5 days prior to epoch change.

I’m good with having to be patient. Just wanting to confirm its not a technical error on my part :slight_smile:

No blocks this next epoch, tho. Wish that were a technical error :rofl:

Andrew Westberg’s cncli leader log usage changed - see:

Are you guys running out of memory during the ledger state extraction by any chance?
cardano-cli query ledger-state is eating up a lot of memory. With 1.25.1 I could still run this on a RPi, but now with 1.27.0 the mem peaks at 10.6Gb.
The EOF error happened with me when the ledger-state extraction was aborted due to running out of mem.