Configure Block producer topology for 2 relay nodes

I’m getting a error right now on block producer
cardano-node: FatalError {fatalErrorMessage = "Cardano.Node.Run.handleSimpleNode .readTopologyFile: Is your topology file formatted correctly? The port and valen cy fields should be numerical. Error in $: not enough input. Expecting object va

Whats the formatting for two?

{
“Producers”: [
{
“addr”: “xxxxx”, <<< relay
“port”: xxxx,
“valency”: 1
},

{
“Producers”: [
{
“addr”: “xxxxx”, <<< relay
“port”: xxxx,
“valency”: 1
},

{
“addr”: “relays-new.cardano-mainnet.iohk.io”,
“port”: 3001,
“valency”: 2
}
]
}

hello,

  • check the character " if you copied from forum (forum change the format for ") delete and write again from keyboard
  • delete the space between }; and {

Cheers,

I dont see };

sorry },

“valency”: 1
},

{

{
“Producers”: [
{
“addr”: “xxxx”, << block producer
“port”: xx,
“valency”: 1
},
{
“addr”: “xxxx”, <<< relay
“port”: xx,
“valency”: 1
},
{
“addr”: “xxxxx”, <<< relay 2
“port”: xx,
“valency”: 1
},
{
“addr”: “relays-new.cardano-mainnet.iohk.io”,
“port”: 3001,
“valency”: 2
}
]
}

In your Producer no need to add in the toplogy file the Producer IP

Okay how abut the relays? Do I set the other relay as a producer or relay in the mainnet-topology?

cat > NODE_HOME/{NODE_CONFIG}-topology.json << EOF
{
“Producers”: [
{
“addr”: “<BLOCK PRODUCER NODE’S PUBLIC IP ADDRESS>”,
“port”: 6000,
“valency”: 1
},
{
“addr”: “relays-new.cardano-mainnet.iohk.io”,
“port”: 3001,
“valency”: 2
}
]
}
EOF

for relays you don’t need to do anything in topology file, just edit the topology updater script, and it will take care of the rest (add your Producer IP and port in topologyupdater script)

the instructions say to create a topology file . my block producer is running well now.

when i registered my pool, i set tax to 0.666% and it set it to 66.6% so i need to fix it :o:

1 Like

create another certification but this time without paying the 500 tax for pool registration

also check your relays, did u configured the topology updater and opened the port 6000?

1 Like

What is the topology updater?

what guide did you followed?

Since the test network has to get along without the P2P network module for the time being, it needs static topology files. This “TopologyUpdater” service, which is far from being perfect due to its centralization factor, is intended to be a temporary solution to allow everyone to activate their relay nodes without having to postpone and wait for manual topology completion requests.

The topologyupdater shell script must be executed on the relay node as a cronjob exactly every 60 minutes . After 4 consecutive requests (3 hours) the node is considered a new relay node in listed in the topology file. If the node is turned off, it’s automatically delisted after 3 hours.

im sitll doing the guide on coin cashew so i havent gone through everything yet.

this is the next step :stuck_out_tongue: about to verify pool id

ok, then follow all the steps

1 Like

stuck on this step:

Copy stakepoolid.txt to your hot environment.

Now that you have your stake pool ID, verify it’s included in the blockchain

cardano-cli query ledger-state --mainnet --allegra-era | grep publicKey | grep $(cat stakepoolid.txt)

cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)xx@ip-xx:~/cardano-my-node$

The command isnt doing anything

my Block node is moving (data showing a lot) But relays only show 1 line and doesnt keep going.

What do u mean?
add a screenshot

Blue = block , purple / red = relays

messaged y ou