Error drafting the transaction (testnet, Following Stake pool school guide)

Trying to “Create a simple transaction”

When trying to “Draft the transaction”

I get this error on the bottom left window.

Not sure what the issue is here, please help.


it is probably a copy-paste typo, try again and make sure all the \ character was copied.

cardano-cli transaction build-raw \
--tx-in 4e3a6e7fdcb0d0efa17bf79c13aed2b4cb9baf37fb1aa2e39553d5bd720c5c99#4 \
--tx-out $(cat payment2.addr)+0 \
--tx-out $(cat payment.addr)+0 \
--invalid-hereafter 0 \
--fee 0 \
--out-file tx.draft

Wow, thank you! that did it! Legend appreciate the fast response!

@laplasz confused why this worked?

Thought my address was e738734d166ed8c5276f95c3478091665719c8ec51c2d048f9b7bcfb945ef994 and the transaction index 0

no - that is not your address instead it is a transactionHash
your address is needed at tx-out and to sign the transaction

Yes sorry I meant to say transactionHash :man_facepalming:

You can see in the above image my transactionHash is

and in the guide, it is the same as what you posted

The guide says to updated it to your own “transactionHash” and when updating it and adding #0 at the end for the TxIn is where the error shows invalid argument

So am I wrong for using my own transactionHash?

yes - the guide is just a demo - so of course you need to adapt your addresses and parameters into the commands to have a successful result

Ok so you were right! It was a copy-paste error for some reason after the \ there was a space and hence the invisibility of the error.

Again thank you for your help, it solved it!

1 Like