Error to submit transaction when sending native tokens to wallet

Hey guys,
I have followed the Cardano tutorial to mint, burn, and transfer native assets and I’m now facing a problem to submitting a transaction to transfer the native asset to a foreign address;

Have someone faced this problem or can tell me what am I missing?

The error is the following:

$ cardano-cli transaction submit --tx-file matx.signed --mainnet
Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (ValueNotConservedUTxO (Value 0 (fromList [(PolicyID {policyID = ScriptHash “dc3cf852aebe652cfa7435149f79bdf3a222aa892988f6a92b8d136a”},fromList [(“Trich Coin”,10000000)])])) (Value 4295985 (fromList [(PolicyID {policyID = ScriptHash “dc3cf852aebe652cfa7435149f722aa892988f6a92b8d136a”},fromList [(“Trich Coin”,10000000)])]))))),UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (BadInputsUTxO (fromList [TxIn (TxId {_unTxId = SafeHash “6685df68633866e36b781d3b11c3a775cc0a4b0d82df8bb9d261e5959b”}) 0]))))])

The result of cardano-cli query utxo address --mainnet is:

I have followed all the steps in the Cardano developers guide:

I would appreciate a lot any help from the community!


You seem to be referencing a UTxO that doesn’t exist

Hi, as @tomdx mentioned, check if you changed the $txhash, $txix and $funds variables to the new ones before building the transaction.

Hey guys, thank you very much for the answers.

I think that there is something being missed in the tutorial;

I did follow all the steps and I’m not using the UTxO that is raising the error as you can see in the image below with all my environment variables:

Do you know why this UTxO / TxIn that is raising the error is being used?


I tried it again using a different wallet and it raised the same error, so I suppose the error is being raised from my side.

I have validated value per value and I really can’t see what’s going wrong.

Any light on this will be very appreciated!

You probably want to show us …

  • output of the address query (i.e. that shows the available UTxO)
  • how you construct the mint Tx

The raw cardano-cli interaction is most helpful.

1 Like

If you follow the guide at Minting Native Assets | Cardano Developer Portal by the letter, it should be rec_matx.signed, not matx.signed for the “sending token to a wallet” step. Could it be just the wrong filename?

1 Like

Heeey!!! Thank you very much man, it worked now

It was totally my fault… When I saved the script I did use the same commands of the minting process to build and sign the transaction :unamused: :roll_eyes: :joy: Newbie stuff

thank you all guys @HeptaSean @tomdx @Couder :heart:

1 Like