Error when executing cardano-cli over node.socket


Yep. Perhaps its a problem with my exposing services to the outside world.

I moved only to a docker image running, using docker run and all the necesary parametters, removing all k8s stuffs. And I still getting the same issue.

CallStack (from HasCallStack):
  error, called at src/Ouroboros/Network/Protocol/LocalStateQuery/Codec.hs:79:7 in ouroboros-network-

However I’m not having in this stage the Notice message. And I’m using the update topology option from nessusio.

I’m using the latest version of nessusio image from which I can inspect, it using the latest version available: 1.27

but this never get fixed somehow?

Nope. I tried some alternatives, but no. The query tips works without --shelley-mode, but this point to Byron era. And other commands, prints an error about it cannot be done in Byron era. And when I use shelley-mode, I get the error message. So I’m stuck right now between these two error messages.

Well, now I’m using the following executables
cardano-cli 1.25 from inside the docker image. (I copied it to the host and using from there to query tips :smiley:)
I did

cardano-cli query tip --shelley-mode --testnet-magic 764824073

And I got

    "blockNo": 111005,
    "headerHash": "c309b1b55f38069a2c336545d5379f26031b0d32d0391e14f017169a317239ab",
    "slotNo": 111034

Now, I’m gonna jump to version 1.26 and see what its there.

As you can see, cardano-cli-1.26.
And the node is running using the following docker image

If I remove --shelley-mode it works. But I don’t know in what is the current era.

    "epoch": null,
    "hash": "9021fc8483e1d5db8b049f9b657b43eb34af1490e672f7fb82322d344a764091",
    "slot": 879280,
    "block": 879182

And also I’m having the same problem that I discussed with @charismatik1 .

This is in mainnet. And using shelley mode I’m getting the same.
Also I run the node the last night in the testnet network. And in the morning, the query tips for the byron era gave me the epoch 135, not null. But the the shelley-mode throws the same exception.

I’m trying to query the node using CARDANO_NODE_SOCKET_PATH variable, but my common user does not have access to the node.socket file. Every time I do it, I use the sudo user. How can I do it with my common user? I tried changin the acces to node.socket using chmod and chown but I didn’t succes. There are some tutorial about it?

Work when I do ./cardano-cli query tip --cardano-mode --testnet-magic 1097911063. This is the output

    "epoch": 83,
    "hash": "5dd93d08553947fb634ab87eaa07ad971013d20c5b8576eae2dd8e5a1493ff5b",
    "slot": 5882828,
    "block": 1808303

I will try to do all the operation for staking pool using that

1 Like

I’m stuck. I still having the same problem. I will make a resumé and put it in the github issue.

1 Like

Nessusio is using 1.25.1 because of this…docs-cardano-org/ at main · cardano-foundation/docs-cardano-org · GitHub

i had the same issue on 1.27 but am going to downgrade to 1.251 per the matrix…

Hi @rmourey26! I got the same issue using the official image in version 1.27, and a different architecture for my machine. The option for me was to wait to node sync, and remove --shelley-mode in the instruction. And it works until now.

not sure if related. But I am also getting the same error using Daedalus testnet macOS build 18213 , Cardano Node 1.26.2 , Cardano Wallet 2021.5.26

❯ cardano-cli query protocol-parameters --shelley-mode --testnet-magic 1097911063

cardano-cli: encodeFailure: local state query: using acquire without a Point must be conditional on negotiating v8 of the node-to-client protocol
CallStack (from HasCallStack):
  error, called at src/Ouroboros/Network/Protocol/LocalStateQuery/Codec.hs:79:7 in rbrs-ntwrk-

Is this a general issue?

Can you describe your overall “cardano-node environment” at the moment of the error? I was running two separate genesis test nodes to re-create/fork the shelly chain, i started the nodes, they were running fine, then ran the cli-query protocol parameters and received the error…

I think its possibly related to previous node socket configurations/file locations and or the cardano-node version… which I’m considering downgrading to 1.25.1 as it’s the only version that can actually run cardano as intended at this point…

Thanks @DiazRock

Not sure how to describe “cardano-node environment” - Is there something I can run on terminal?

Hello, have you figured out a solution? I have run into the same problem.

Turns out I just needed to wait for the node to sync!