Error when executing cardano-cli over node.socket

I’m using cardano-cli 1.27.0 - linux-x86_64 - ghc-8.10 git rev 709a259403c0ba03988950c0e4696d7457a3a5aa version. I have a docker-compose running two services, from relay_nodes.
I execute cardano-cli query protocol-parameters --shelley-mode --testnet-magic 1097911063 --out-file protocol.json, pointing to the node.socket of the first service, let’s call it relay1.
So, I’m getting this error:

cardano-cli: encodeFailure: local state query: using acquire without a Point must be conditional on negotiating v8 of the node-to-client protocol CallStack (from HasCallStack): error, called at src/Ouroboros/Network/Protocol/LocalStateQuery/Codec.hs:79:7 in ouroborosnetwork0.1.0.04jeKomdFdXlCG0PGFQPwJS:Ouroboros.Network.Protocol.LocalStateQuery.Codec

Why is this? Should I turn off one of the services and try the command with relay1 on?

3 Likes

I tried with a node outside a container. But I get the same error. I tried with only a container (relay1 as I said), and the same result.

Hi DiazRock. I ran into the same problem when trying to make a leaderlog query on my mainnet BP. After hours of trying a lot of other things i simply tried to query without --shelley-mode and it worked.

Just ran cardano-cli query protocol-parameters --mainnet without an error too.

Hope this helps,
cheers LSD pool

1 Like

Hi @charismatik1 . That’s a good option. But I want to try in testnet first. Even I also claim a faucet in a page. Nevertheless, I tried without --shelley-mode, and It gives me an error related to byron era. I arrived to –shelley-mode because of that error. I try to use another version of the node and the node cli. Where can I found it?

That is interesting… i think it is better to submit an issue in github:

1 Like

also could you try this with 1.26.2?

1 Like

Yes. I’m trying to build cardano-cli for 1.26. There is some binary in some place?

yes, you can download the binaries for a specific release:

1 Like

I tried with other version. With 1.26. And it gives me a very similar error. I put it in the issue on github.

1 Like

btw, earlier versions docker images also available with using the specific tag

1 Like

Yes. And I used an earlier one. 1.26.2

1 Like

and btw can you query the tip?

What means query the tip? Write the error? I putted it.

cardano-cli query tip --testnet-magic 1097911063
https://docs.cardano.org/projects/cardano-node/en/latest/stake-pool-operations/simple_transaction.html#determine-the-ttl-time-to-live-for-the-transaction

1 Like

This is the output

{
    "epoch": 2,
    "hash": "f1c204d75603903e0426dd1cd64bc39676527b906e96cba6415f8c84b729052a",
    "slot": 59220,
    "block": 58190,
    "era": "Byron"
}

And using shelley-mode

{
    "epoch": null,
    "hash": "8fd23b1ba9dc5814820ea9f9f0e5b6daa50053eeacc9c3573fb2815893f803f3",
    "slot": 61096,
    "block": 60066,
    "era": "Shelley"
}

ok - I am not sure but perhaps better to wait till the node is in sync, on testnet the epoch is around 130:
https://explorer.cardano-testnet.iohkdev.io/en
so checking the tip is useful to get the current sync status of the node

So perhaps is an issue of internet or connectivity?

I’m getting Unsupported mode: ShelleyMode, in the output of the shelley-mode tip.

No - the node is syncing - wait till it is full synced. And you can check the status of the syncing by querying the actual tip of the chain

1 Like

Well, I’m getting the same issue using another bandwith. But I’m getting this log a lot of times in my nodes:

Notice: TraceForwarder's queue is full, 200 log items were dropped!

I’m using
cardano-cli 1.27.0 - linux-aarch64 - ghc-8.10
git rev 8fe46140a52810b6ca456be01d652ca08fe730bf

And the latest version of cardano nessusio docker image for arm

And I’m using a k8s cluster. Perhaps if I try without the k8s I don’t going to get that error.