Attempting to get Tip from mainnet throws error

So I can’t see any information other than the Ouroboros general error. But I have my node running and it’s extending the chain etc, but I am attempting to do some initial setups for the stake pool.

I have generated all kinds of keys from all of the documentation, but at the point where I need to check if it is syncing with the cli I get an error:

Note: This is on Windows 10 machine in powershell

So I issue the command: .\cardano-cli shelley query tip --mainnet

And rather that spitting out the slotNo/blockNo etc, I get the following:

cardano-cli.exe: DecoderFailure (Handshake) ServerAgency TokConfirm) (DeserialiseFailure 2 “codecHandshake.Confirm: unexpected key”)

Wondering if anyone has had this, is having this, and maybe has a solution or a reason why this happens?

Ok so I re-ran all the setup things on linux, and I think the issue is the CARDANO_NODE_SOCKET_PATH setting in the system environment variables… for some reason it does NOT like it. I have even done the ‘refreshenv’ and closed powershells, then restarted everything up and tried the commands and it doesn’t work still.

First time running it on Linux worked like a charm. It’s simply the simplicity of the