DecoderFailure in cardano-cli

I’m facing some issues with cardano-cli. I’m using the Daedalus socket and trying to query the testnet.

When running this command cardano-cli query tip --testnet-magic 1097911063 it returns the following:

cardano-cli: DecoderFailure (LocalStateQuery HardForkBlock (': * ByronBlock (': * (ShelleyBlock (ShelleyEra StandardCrypto)) (': * (ShelleyBlock (ShelleyMAEra 'Allegra StandardCrypto)) (': * (ShelleyBlock (ShelleyMAEra 'Mary StandardCrypto)) ('[] *))))) Query (HardForkBlock (': * ByronBlock (': * (ShelleyBlock (ShelleyEra StandardCrypto)) (': * (ShelleyBlock (ShelleyMAEra 'Allegra StandardCrypto)) (': * (ShelleyBlock (ShelleyMAEra 'Mary StandardCrypto)) ('[] *))))))) ServerAgency TokQuerying QueryHardFork GetCurrentEra) (DeserialiseFailure 3 "EraIndex: invalid index 4")

However when executing cardano-cli get-tip --testnet-magic 1097911063 it works fine.

What could be causing this? Any thoughts on what I might be missing?

The node is fully sync?
If no wait til will be, if yes try to download the files from here

Hey @Alexd1985,
Yes, Daedalus is fully synched.
From my very basic understanding those files are used as part of the “cardano-node run”, and I don’t know how I can make Daedalus use them.
Is there any documentation that details the steps required?

What operating system do u have?

I’m using Linux, Debian based distro.
Could this be related to the era?

Here u should find the config files


Unfortunately, there are no config files there.
This is the contents of the testnet directory:
cardano-node.socket chain daedalus_lockfile icon_large.png icon.png Logs namespaceHelper Secrets tls wallets
Also no config files on the sub-directories

Then it should be located to another location… the folder is named files and inside u should find topology.json and the config files


The default topology file location on Linux is:
where XXX is series of characters but to find out what is that you can search for the file with find ~/ -name "topology.yaml"

Run ps auxf | grep cardano-node and see from the running process parameters the file locations.

1 Like

Thanks, I was able to find them in this location ~/.daedalus/nix/store/XXX-node-cfg-files/topology.yaml
After modifying the: config.yaml, genesis.json and topology.yaml files, Daedalus was throwing an error at startup and wouldn’t launch.
To get Daedalus working I changed the config.yaml and genesis.json to the original files. However I’m still getting the same error.

Seems like Daedalus is causing this. Do you think I should just remove Daedalus and run the raw “cardano-node run”, or is there any alternative?

What files are inside the folder?

Just the config ones:
config.yaml genesis.json topology.yaml

For anyone experiencing the same issue, I was using an outdated version of cardano-cli, after updating it everything worked fine.

Thanks @Alexd1985 and @mcrio :slight_smile:

1 Like