Error while Minting NFT transaction using full node

I’m getting error on asset name for --tx-out as well as --mint. My Cardano full node version is 1.31.0.

…/cardano/cardano-cli transaction build-raw
–fee $txnfee
–tx-in “07a1a75d4d022c6bb988c9797862998d456a1384a83feb4af568b21fa4a0dec9#0”
–tx-out addr1qyk5z9eltwxy53anlulq0yx3npapvx2ghs80kg5ghszmsyp8jyyvzx6mjrlcv80q8a22rn3decgx47km3vj4ycdyhc2qj39khr+2828691+“1 614d432e7bfbad362a5b55fe7f86d5471add05d6a834972c0b0471dd.test”
–mint “1 614d432e7bfbad362a5b55fe7f86d5471add05d6a834972c0b0471dd.test”
–minting-script-file policy/policy.script
–metadata-json-file metadata.json
–out-file matx.raw

option --tx-out:
unexpected ‘t’
expecting alphanumeric asset name, white space, “+” or end of input

I tried using different names for the asset, none of them worked. Not sure what I’m doing wrong.
Asset name here in the above example is “test”.

You need to use base16 (hex encoded) values so for “test” it would be asset name “74657374”

That worked thanks!!!

No problem,

Note you can use various free online tools if encoding/decoding with code is not your bag. The concept remains the same though. We have ASCII single byte characters which can be represented numerically. There are many numeric representations used by computers such as binary, octal, decimal, and hexadecimal.

So if capital ‘A’ is code for numeric value 65 then the hex value would be 0x41 and we can translate these representations back and forth easily. Try spelling your name in binary for fun sometime if you really want to nerd out …