Jormungandr 0.8.9 not bootstraping in itn_rewards_v1

@kenichi-satou please find section “trusted-peers” in your jormungandr -config file and keep it updated with active peers you can find in https://adapools.org/peers

My working list is:

"trusted_peers": [
    {"address":"/ip4/185.164.6.221/tcp/54322","id":"64e8a1acfd065102fe268fd874f00e910e1794eb49ec71d6"},
      {
        "address": "/ip4/3.124.116.145/tcp/3000",
        "id": "99cb10f53185fbef110472d45a36082905ee12df8a049b74"
      },
      {
        "address": "/ip4/52.9.132.248/tcp/3000",
        "id": "671a9e7a5c739532668511bea823f0f5c5557c99b813456c"
      },
      {
        "address": "/ip4/13.112.181.42/tcp/3000",
        "id": "52762c49a84699d43c96fdfe6de18079fb2512077d6aa5bc"
      },
      {
        "address": "/ip4/18.184.35.137/tcp/3000",
        "id": "06aa98b0ab6589f464d08911717115ef354161f0dc727858"
      },
      {
        "address": "/ip4/18.182.115.51/tcp/3000",
        "id": "8529e334a39a5b6033b698be2040b1089d8f67e0102e2575"
      },
      {
        "address": "/ip4/18.177.78.96/tcp/3000",
        "id": "fc89bff08ec4e054b4f03106f5312834abdf2fcb444610e9"
      },
      {
        "address": "/ip4/52.28.91.178/tcp/3000",
        "id": "23b3ca09c644fe8098f64c24d75d9f79c8e058642e63a28c"
      },
      {
        "address": "/ip4/54.183.149.167/tcp/3000",
        "id": "df02383863ae5e14fea5d51a092585da34e689a73f704613"
      },
      {
        "address": "/ip4/52.8.15.52/tcp/3000",
        "id": "18bf81a75e5b15a49b843a66f61602e14d4261fb5595b5f5"
      }
    ]
1 Like

Here is an alternate version of jormungandr-config.yaml that adds four of my private peers:

2 Likes

Thank you for your support.
Now, I am trying to execute with the following configuration file.

{ "log": [ { "format": "plain", "level": "info", "output": "stderr" } ], "storage": "./storage/", "p2p": { "listen_address": "/ip4/0.0.0.0/tcp/3000", "public_address": "/ip4/<my adderss>/tcp/3000", "topics_of_interest": { "blocks": "high", "messages": "high" }, "trusted_peers": [ {"address":"/ip4/185.164.6.221/tcp/54322","id":"64e8a1acfd065102fe268fd874f00e910e1794eb49ec71d6"}, { "address": "/ip4/3.124.116.145/tcp/3000", "id": "99cb10f53185fbef110472d45a36082905ee12df8a049b74" }, { "address": "/ip4/52.9.132.248/tcp/3000", "id": "671a9e7a5c739532668511bea823f0f5c5557c99b813456c" }, { "address": "/ip4/13.112.181.42/tcp/3000", "id": "52762c49a84699d43c96fdfe6de18079fb2512077d6aa5bc" }, { "address": "/ip4/18.184.35.137/tcp/3000", "id": "06aa98b0ab6589f464d08911717115ef354161f0dc727858" }, { "address": "/ip4/18.182.115.51/tcp/3000", "id": "8529e334a39a5b6033b698be2040b1089d8f67e0102e2575" }, { "address": "/ip4/18.177.78.96/tcp/3000", "id": "fc89bff08ec4e054b4f03106f5312834abdf2fcb444610e9" }, { "address": "/ip4/52.28.91.178/tcp/3000", "id": "23b3ca09c644fe8098f64c24d75d9f79c8e058642e63a28c" }, { "address": "/ip4/54.183.149.167/tcp/3000", "id": "df02383863ae5e14fea5d51a092585da34e689a73f704613" }, { "address": "/ip4/52.8.15.52/tcp/3000", "id": "18bf81a75e5b15a49b843a66f61602e14d4261fb5595b5f5" } ] }, "rest": { "listen": "127.0.0.1:3100" } }

It started 30 minutes later, but I could see some errors in the logs.

Feb 13 02:02:31.802 INFO failed to connect to peer, reason: Connection timed out (os error 110), node_id: 18bf81a75e5b15a49b843a66f61602e14d4261fb5595b5f5, peer_addr: 52.8.15.52:3000, task: network Feb 13 02:02:32.224 INFO connection to peer failed, reason: protocol handshake failed: unknown error (grpc-status: Unknown, grpc-message: "connection error: broken pipe"), node_id: 23b3ca09c644fe8098f64c24d75d9f79c8e058642e63a28c, peer_addr: 52.28.91.178:3000, task: network

Even after nearly an hour, it does not seem to receive the block.

this command is

./jcli rest v0 node stats get --host “http://127.0.0.1:3100/api
The next does not change.

result

blockRecvCnt: 0
lastBlockContentSize: 0
lastBlockDate: “60.38587”
lastBlockFees: 0

Probably the IOHK node is set to avoid being added as a peer from many nodes. I think it can be solved by adding a private peer.

Thanks to you I was saved.

1 Like

Thank you.
I’m also experimenting with adding four private peers now.

That’s excellent. A block has been received.


$ ./jcstrong textli rest v0 node stats get --host “http://127.0.0.1:3100/api

blockRecvCnt: 62
lastBlockContentSize: 315
lastBlockDate: “60.40612”
lastBlockFees: 800000
lastBlockHash: 2e70840b63b01902eef7b853bb79044647219959be67d9ca8050d20b5a58bc2f
lastBlockHeight: “192697”
lastBlockSum: 150000000
lastBlockTime: “2020-02-12T17:47:21+00:00”
lastBlockTx: 1
lastReceivedBlockTime: “2020-02-12T17:47:21+00:00”
peerAvailableCnt: 6
peerQuarantinedCnt: 8
peerUnreachableCnt: 0
state: Running
txRecvCnt: 0
uptime: 283
version: jormungandr 0.8.9-30d20d2

Thanks to you I was saved.

1 Like

Excellent! :trophy:

1 Like

Here’s the config I used for a small passive node showing how to add max_reboot_attempts which worked for me.

Hopefully posting this via email won’t mess up the code.

1 Like

I guess it did not work through email.
Second try.

---
leadership:
    garbage_collection_interval: 30m
    log_ttl: 24h
log:
- format: plain
  level: warn
  output: stderr
mempool:
    fragment_ttl: 30m
    garbage_collection_interval: 5m
    log_max_entries: 200000
    log_ttl: 1h
    pool_max_entries: 20000
rest:
  listen: "127.0.0.1:<REST_PORT>"
storage: <Chain_Storage_Location>
p2p:
  gossip_interval: 10s
  listen_address: "/ip4/0.0.0.0/tcp/<P2P_Port>"
  max_bootstrap_attempts: 0
  max_connections: 160
  max_unreachable_nodes_to_connect_per_event: 16
  public_address: "/ip4/<Public_IP>/tcp/<P2P_Port>"
  public_id: <Public_Id>
  topics_of_interest:
    blocks: normal
    messages: normal
  trusted_peers:
  - address: "/ip4/54.183.149.167/tcp/3000"
    id: df02383863ae5e14fea5d51a092585da34e689a73f704613
[... other trusted peers ...]
1 Like

The configuration file that you taught me was very interesting because it contained many configuration items that I did not know. I will try running this way. If you do not mind,can you tell me which document describes these settings?

This is a good starting point: https://input-output-hk.github.io/jormungandr/configuration/introduction.html

I think it is a little out of date.

CH said in his latest update that they are working on updating the docs.

Other thing sin my config came from people on the Telegram channel.

Shawn

1 Like

Thank you very much. I study hard.

I did follow steps from instruction and here is my configuration
{
“log”: [
{
“format”: “plain”,
“level”: “info”,
“output”: “stderr”
}
],
“storage”: “./storage/”,
“p2p”: {
public_address: “/ip4/0.0.0.0/tcp/3000”
,listen_address: “/ip4/0.0.0.0/tcp/3000”
,“topics_of_interest”: {
“blocks”: “high”,
“messages”: “high”
},
“trusted_peers”: [
{“address”:"/ip4/45.153.184.124/tcp/3000", “id”:“45c0b4aec64b87c791ced181654f94ac546204cd5684c62e”},
{“address”:"/ip4/45.153.184.127/tcp/3000", “id”:“1ed034f97b3bf86fe2832cfd99b7b3b329a8be35543fa638”},
{“address”:"/ip4/45.153.186.205/tcp/3000", “id”:“faabe8ab376a4476e5e3b4ad627e9e9c5210499ebe5b27a1”},
{“address”:"/ip4/45.153.187.120/tcp/3000", “id”:“09b13fac5c8ce898a5744ed8a4359b8cea846a188c31bf4b”},
{
“address”: “/ip4/13.56.0.226/tcp/3000”,
“id”: “7ddf203c86a012e8863ef19d96aabba23d2445c492d86267”
},
{
“address”: “/ip4/52.28.91.178/tcp/3000”,
“id”: “23b3ca09c644fe8098f64c24d75d9f79c8e058642e63a28c”
},
{
“address”: “/ip4/3.125.75.156/tcp/3000”,
“id”: “22fb117f9f72f38b21bca5c0f069766c0d4327925d967791”
},
{
“address”: “/ip4/13.112.181.42/tcp/3000”,
“id”: “52762c49a84699d43c96fdfe6de18079fb2512077d6aa5bc”
},
{
“address”: “/ip4/13.114.196.228/tcp/3000”,
“id”: “7e1020c2e2107a849a8353876d047085f475c9bc646e42e9”
},
{
“address”: “/ip4/52.8.15.52/tcp/3000”,
“id”: “18bf81a75e5b15a49b843a66f61602e14d4261fb5595b5f5”
},
{
“address”: “/ip4/52.9.132.248/tcp/3000”,
“id”: “671a9e7a5c739532668511bea823f0f5c5557c99b813456c”
},
{
“address”: “/ip4/3.125.183.71/tcp/3000”,
“id”: “9d15a9e2f1336c7acda8ced34e929f697dc24ea0910c3e67”
},
{
“address”: “/ip4/54.183.149.167/tcp/3000”,
“id”: “df02383863ae5e14fea5d51a092585da34e689a73f704613”
},
{
“address”: “/ip4/3.124.116.145/tcp/3000”,
“id”: “99cb10f53185fbef110472d45a36082905ee12df8a049b74”
},
{
“address”: “/ip4/52.9.77.197/tcp/3000”,
“id”: “fcdf302895236d012635052725a0cdfc2e8ee394a1935b63”
},
{
“address”: “/ip4/18.177.78.96/tcp/3000”,
“id”: “fc89bff08ec4e054b4f03106f5312834abdf2fcb444610e9”
},
{
“address”: “/ip4/3.115.154.161/tcp/3000”,
“id”: “35bead7d45b3b8bda5e74aa12126d871069e7617b7f4fe62”
},
{
“address”: “/ip4/18.182.115.51/tcp/3000”,
“id”: “8529e334a39a5b6033b698be2040b1089d8f67e0102e2575”
},
{
“address”: “/ip4/18.184.35.137/tcp/3000”,
“id”: “06aa98b0ab6589f464d08911717115ef354161f0dc727858”
},
{
“address”: “/ip4/3.125.31.84/tcp/3000”,
“id”: “8f9ff09765684199b351d520defac463b1282a63d3cc99ca”
},
{
“address”: “/ip4/3.125.183.71/tcp/3000”,
“id”: “9d15a9e2f1336c7acda8ced34e929f697dc24ea0910c3e67”
}
]
},
“rest”: {
“listen”: “127.0.0.1:3101”
}
}

However, when I show result sync peer it seemed that I still can’t get update from peer yet
blockRecvCnt: 0

lastBlockContentSize: 0

lastBlockDate: “154.13397”

lastBlockFees: 0

lastBlockHash: 235c8864b18b99372092d4c32a1f45867d50295b5e9ad4485ab2c39f31dac36c

lastBlockHeight: “554456”

lastBlockSum: 0

lastBlockTime: “2020-05-16T02:40:11+00:00”

lastBlockTx: 0

lastReceivedBlockTime: ~

nodeId: c0faf4baafa54279a3a867938fb89682f89559df91850cae

peerAvailableCnt: 2

peerConnectedCnt: 2

peerQuarantinedCnt: 18

peerTotalCnt: 20

peerUnreachableCnt: 0

state: Running

txRecvCnt: 0

uptime: 299

And also I got some error message like this

May 16 03:36:04.140 INFO connection to peer failed , reason : protocol handshake failed: unknown error (grpc-status: Unknown, grpc-message: “connection error: broken pipe”), node_id : 99cb10f53185fbef110472d45a36082905ee12df8a049b74, peer_addr : 3.124.116.145:3000, task : network
May 16 03:36:13.876 INFO peer node ID differs from the expected faabe8ab376a4476e5e3b4ad627e9e9c5210499ebe5b27a1 , node_id : 09b13fac5c8ce898a5744ed8a4359b8cea846a188c310000, peer_addr : 45.153.186.205:3000, task : network

Please help to advise what I did wrong. Thank you.

Now it already worked.

1 Like