Problems running ``

I have a lot of errors but I think my node is syncing the block chain now. because I can create my stake pool.
Also, I found out some of peer nodes would be dead.
So, I rewrote the config.yaml to the below active peer address.

I want to confirm with an IOHK devops engineer that that list is officially approved. @disasm, is it advisable to rewrite config.yaml to connect to the peers at

@disasm Is there a more official up to date list that is recommended for stake pool operators?

When I put ./ 3100 10000 749/10000 100000000000 dhdhdhhPRIVATE_KEY_SKhdhdhd | tee createStakePool_output.txt

Output a error like this:
invalid Bech32
|-> invalid length
error: The following required arguments were not provided:


##3. Create the Stake Pool certificate using above VRF and KEY public keys
error: The argument ‘–owner <OWNER_KEY>…’ requires a value but none was supplied

what happened?

For an official to recommend something unofficial, they have to put it through an official process. It might take time, or not happen at all. The adapools people are respected members of the community, plently of people are using this method, there really is nothing to worry about.

1 Like

@El_Bap, it looks like you have an extra arg in there before your private key.

./ 3100 10000 749/10000 $PRIVATE_KEY_SK | tee createStakePool_output.txt

In other words take out the 100000000000

Well I have set the official way going my whole work day and the unofficial way going during my time at the bouldering gym. Neither have worked which is very disappointing.

All the peers you see in the list are from IOHK indeed.
The original set of peers in config here is what end users using Daedalus Rewards wallets connect to (unless config is modified).
The additional set of peers in config here was added by IOHK devops specifically for stake pool operators.
ADAPools are using the peers from both the list to combine and present the results.

As regards why it doesnt work for you, its a lot more involved discussion :slight_smile: More importantly, its not part of the discussion in this thread.


If you are having problems getting working because your jormungandr node won’t sync, see @ATADA 's post here for some good peers:

@El_Bap Now I am getting the same error you got. But I figured it out. You may have used the pool address instead of the PRIVATE_KEY_SK

You are right. All is OK now. I taked out 1000000000. Thanks

Hi dbwest, I had the same problem as csa86. After I sent funds (from Daedalus - Rewards wallet) to the ADDRESS field generated by the, I got this same ‘REST’ API call error:
$ ./jcli rest v0 account get $ADDRESS -h
failed to make a REST request
|-> node rejected request because of invalid parameters
|-> Client Error: 404 Not Found

Before I ran the account balance api call, I’ve also checked and made sure that my jormungandr node (version: jormungandr 0.8.10) was in sync. CARDANO EXPLORER INCENTIVIZED TESTNET did show the $ADDRESS had more than 1000 ADA. I’m stuck at this step. Can you think of any other cases that can cause this problem? Thank you.
P.S. Another question: “dc9b336619522d5f6d893bd700c0bc14c22e15f0f0c3dfeca37d8ed91f7b4f46” where did hash value come from? it was not the value from $ADDRESS.

Problem solved by following instructions on Step 3 of the PoA Guide:


Thank you for letting us know. (congrats to @cryptocreampuff for setting up this guide. :ok_hand:)

1 Like