Help with registering stake pool

Hello,

so after several hours trying to figure out what is wrong, I decided to ask here for help. I have been trying to register my first stake pool, but I am failing when finalizing transaction.

I am getting this error message:
Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraMary (ApplyTxError [UtxowFailure (UtxoFailure (ValueNotConservedUTxO (Value 601817955 (fromList )) (Value 1101817955

My ADA balance is 601, I am trying to pledge with 100 ADA. I do not understand, why there is some difference of 500 ADA in the error message - (Value 1101817955)

I followed this guides:

https://docs.cardano.org/projects/cardano-node/en/latest/stake-pool-operations/register_stakepool.html

and when I was building the transaction, I specified everything that is needed exactly as in those both documents.

calculate change: UTxO BALANCE - poolDeposit - TRANSACTION FEE

–tx-out $(cat payment.addr)+CHANGE IN LOVELACE \

Can someone help me figure out what am I doing wrong here?

Thanks
Jakub

Perhaps u paid 500 ADA for registration and the wallet has less balance?

Hey Alex, no thats not it. My balance was and still is 601 ADA. So that should cover everything I need. 100 pledge + 500 deposit easilly.

hello i need help with this error please

DelegsFailure (DelplFailure (DelegFailure (StakeKeyAlreadyRegisteredDELEG

The address is already delegated

thanks, i connected everything, look good, how to check if my BlockProducer computer is actually connected to relay computer???

Uptime: 00:55:59 β”‚ Port: 6000 β”‚ Guild LiveView v1.20.9 β”‚
β”‚------------------------└────────────┴─────────────────────────
β”‚ Epoch 274 [65.9%] (node) β”‚
β”‚ 1d 16:53:59 until epoch boundary (chain) β”‚
β”‚ β–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β–– β”‚
β”‚ β”‚
β”‚ Block : 5908778 Tip (ref) : 33289561 β”‚
β”‚ Slot : 284740 Tip (node) : 33289540 β”‚
β”‚ Density : 4.905 Tip (diff) : 21 :slight_smile: β”‚
β”‚--------------------------------------------------------------β”‚
β”‚ Processed TX : 0 Out / In β”‚
β”‚ Mempool TX/Bytes : 0 / 0 Peers : 24 1

i have like this for 2 days now, is it correct???

Nope, it seems the producer is not connected to the Relay

  • check the topology file from producer
  • check the topology updater script from relay (the IP+port if the Producer should be added to the custom peers line + uncomment the line inside the topologyUpdater.sh script)
  • check the firewalls rules (the producer should accept connections only from the relay and the relay should accept connections from any)

Cheers

thanks, will try, do you have command line i can follow??

"resultcode": "201", "networkMagic": "764824073", "ipType":6, "requestedIpVersion":"4", "Producers": [ 
  { "addr": "192.168.1.122", "port": 6000, "valency": 1 } ,
  { "addr": "relays-new.cardano-mainnet.iohk.io", "port": 3001, "valency": 2 } ,
  { "addr": "207.244.248.254", "port": 6000, "valency": 1, "distance":9,  "continent":"NA",  "country":"US",  "region":"MO" },
  { "addr": "35.192.109.81", "port": 3001, "valency": 1, "distance":557,  "continent":"NA",  "country":"US",  "region":"IA" },
  { "addr": "172.8.215.51", "port": 6001, "valency": 1, "distance":798,  "continent":"NA",  "country":"US",  "region":"OH" },
  { "addr": "18.233.2.110", "port": 6000, "valency": 1, "distance":1108,  "continent":"NA",  "country":"US",  "region":"VA" },
  { "addr": "74.208.253.198", "port": 6000, "valency": 1, "distance":1287,  "continent":"NA",  "country":"US",  "region":"PA" },
  { "addr": "161.35.2.194", "port": 6001, "valency": 1, "distance":1412,  "continent":"NA",  "country":"US",  "region":"NY" },
  { "addr": "75.119.148.112", "port": 3001, "valency": 1, "distance":1657,  "continent":"NA",  "country":"DE",  "region":"FL" },
  { "addr": "52.41.142.25", "port": 3001, "valency": 1, "distance":2537,  "continent":"NA",  "country":"US",  "region":"OR" },
  { "addr": "138.68.252.24", "port": 6000, "valency": 1, "distance":2792,  "continent":"NA",  "country":"US",  "region":"CA" },
  { "addr": "82.13.217.189", "port": 4002, "valency": 1, "distance":6758,  "continent":"EU",  "country":"GB",  "region":"ENG" },
  { "addr": "142.93.228.168", "port": 9630, "valency": 1, "distance":7020,  "continent":"EU",  "country":"NL",  "region":"NH" },
  { "addr": "194.163.132.30", "port": 6001, "valency": 1, "distance":7215,  "continent":"EU",  "country":"DE",  "region":"NW" },
  { "addr": "164.90.175.111", "port": 6001, "valency": 1, "distance":7368,  "continent":"EU",  "country":"DE",  "region":"HE" },
  { "addr": "81.169.200.102", "port": 6000, "valency": 1, "distance":7488,  "continent":"EU",  "country":"DE",  "region":"BE" },
  { "addr": "168.119.230.220", "port": 3333, "valency": 1, "distance":7553,  "continent":"EU",  "country":"DE",  "region":"BY" },
  { "addr": "62.171.184.119", "port": 4002, "valency": 1, "distance":7668,  "continent":"EU",  "country":"DE",  "region":"BY" },
  { "addr": "144.91.105.220", "port": 6000, "valency": 1, "distance":7668,  "continent":"EU",  "country":"DE",  "region":"BY" },
  { "addr": "195.191.47.214", "port": 6000, "valency": 1, "distance":8781,  "continent":"EU",  "country":"RO",  "region":"B" },
  { "addr": "yakisoba.daemon.asia", "port": 6000, "valency": 1, "distance":10938,  "continent":"AS",  "country":"JP",  "region":"40" },
  { "addr": "101.191.203.236", "port": 3001, "valency": 1, "distance":14552,  "continent":"OC",  "country":"AU",  "region":"NSW" },
  { "addr": "51.79.160.54", "port": 3001, "valency": 1, "distance":15319,  "continent":"AS",  "country":"SG",  "region":"01" }

this is on my relay

Ok, the above pics it’s from relay right? If u check the producer u have 1IN/1OUT peers right?

Then on relay u should check if the topology updater run every hour

Also check if the port 6000 is open to allow connections from outside

https://www.yougetsignal.com/tools/open-ports/

[sudo] password for cardanor1:
Status: active

 To                         Action      From
 --                         ------      ----

[ 1] 22/tcp ALLOW IN Anywhere
[ 2] 6000/tcp ALLOW IN Anywhere
[ 3] 123/udp ALLOW IN Anywhere
[ 4] 6000 ALLOW IN 192.168.1.122
[ 5] 22/tcp (v6) ALLOW IN Anywhere (v6)
[ 6] 6000/tcp (v6) ALLOW IN Anywhere (v6)
[ 7] 123/udp (v6) ALLOW IN Anywhere (v6)
hello Alexd1985, still i am stuck, do not know what to do, above is my relay node firewall setting, if everything is okay???
my relay node is not adding Processed Tx for the last 4 days???
any way to help?

my relay node topology
GNU nano 4.8 mainnet-topology.json

 {
    "Producers": [
      {
        "addr": "192.168.1.122",
        "port": 6000,
        "valency": 1
      },
      {
        "addr": "relays-new.cardano-mainnet.iohk.io",
        "port": 3001,
        "valency": 2
      }
    ]
  }

here my block node , this one also
BlockNode Topology

{
    "Producers": [
      {
        "addr": "192.168.1.171",
        "port": 6000,
        "valency": 1
      }
    ]
  }

BlockNode Firewall
cardanop1@M5:~/cardano-my-node$ sudo ufw status numbered
Status: active

     To                         Action      From
     --                         ------      ----
[ 1] 6000/tcp                   ALLOW IN    Anywhere                  
[ 2] 6000/tcp                   ALLOW IN    192.168.1.171             
[ 3] 6000                       ALLOW IN    192.168.1.171             
[ 4] 22/tcp                     ALLOW IN    Anywhere                  
[ 5] 123/udp                    ALLOW IN    Anywhere                  
[ 6] 6000/tcp (v6)              ALLOW IN    Anywhere (v6)             
[ 7] 22/tcp (v6)                ALLOW IN    Anywhere (v6)             
[ 8] 123/udp (v6)               ALLOW IN    Anywhere (v6)

from relay ufw delete:
[ 4] 6000 ALLOW IN 192.168.1.122

from Producer ufw delete:
[ 6] 6000/tcp (v6) ALLOW IN Anywhere (v6)

and now, for the relay u should run the topologyupdater once/hour, otherwise your node will be declared offline

thanks, so i did that this is Producer,
i will restart , then will do the topologyUpdater.sh ???
tatus: active

     To                         Action      From
     --                         ------      ----
[ 1] 6000/tcp                   ALLOW IN    Anywhere                  
[ 2] 6000/tcp                   ALLOW IN    192.168.1.171             
[ 3] 6000                       ALLOW IN    192.168.1.171             
[ 4] 22/tcp                     ALLOW IN    Anywhere                  
[ 5] 123/udp                    ALLOW IN    Anywhere                  
[ 6] 22/tcp (v6)                ALLOW IN    Anywhere (v6)             
[ 7] 123/udp (v6)               ALLOW IN    Anywhere (v6)

and this one is relay
tatus: active

     To                         Action      From
     --                         ------      ----
[ 1] 22/tcp                     ALLOW IN    Anywhere                  
[ 2] 6000/tcp                   ALLOW IN    Anywhere                  
[ 3] 123/udp                    ALLOW IN    Anywhere                  
[ 4] 22/tcp (v6)                ALLOW IN    Anywhere (v6)             
[ 5] 6000/tcp (v6)              ALLOW IN    Anywhere (v6)             
[ 6] 123/udp (v6)               ALLOW IN    Anywhere (v6)

No Process Tx yet, and evertime i update, get this massage
cardanor1@ali:~/cardano-my-node$ ./topologyUpdater.sh

{ 
   "resultcode": "504", 
   "datetime":"2021-06-29 04:14:45", 
   "clientIp": "2600:1700:f008:2150:ec25:1741:3992:a992", 
   "iptype": 6, 
   "msg": "one request per hour please"
}

Is it peferct, wait for the script to run 3 times… did u added the Producer IP+port inside the topologyupdater script from the relay (to custom peers line)

yes, this one

On relaynode1

cat > $NODE_HOME/relay-topology_pull.sh << EOF

#!/bin/bash

BLOCKPRODUCING_IP=192.168.1.122

BLOCKPRODUCING_PORT=6000

curl -s -o $NODE_HOME/${NODE_CONFIG}-topology.json β€œhttps://api.clio.one/htopology/v1/fetch/?max=20&customPeers=${BLOCKPRODUCING_IP}:${BLOCKPRODUCING_PORT}:1|relays-new.cardano-mainnet.iohk.io:3001:2”

EOF

i fall sleep after second one, but after 4 hrs i did this, still i have 0 tx
cardanor1@ali:~/cardano-my-node$ cd $NODE_HOME

cardanor1@ali:~/cardano-my-node$ chmod +x topologyUpdater.sh

cardanor1@ali:~/cardano-my-node$ ./topologyUpdater.sh

{ β€œresultcode”: β€œ504”, β€œdatetime”:β€œ2021-06-29 10:33:35”, β€œclientIp”: β€œ2600:1700:f008:2150:9336:6514:6e99:f908”, β€œiptype”: 6, β€œmsg”: β€œone request per hour please” }

ardanor1@ali:~/cardano-my-node$ ###

cardanor1@ali:~/cardano-my-node$ ### On relaynode1

cardanor1@ali:~/cardano-my-node$ ###

cardanor1@ali:~/cardano-my-node$ cat > $NODE_HOME/relay-topology_pull.sh << EOF

#!/bin/bash

BLOCKPRODUCING_IP=192.168.1.122

BLOCKPRODUCING_PORT=6000

curl -s -o $NODE_HOME/${NODE_CONFIG}-topology.json β€œhttps://api.clio.one/htopology/v1/fetch/?max=20&customPeers=${BLOCKPRODUCING_IP}:${BLOCKPRODUCING_PORT}:1|relays-new.cardano-mainnet.iohk.io:3001:2”

EOF

cardanor1@ali:~/cardano-my-node$