Relay node on Mac Mini M1

Hi @Alexd1985

I am trying to migrate away from cloud and set up a relay node in a Mac Mini M1.

I found this tutorial but it is a Docker image.

Is there any guide similar to CoinCashew which shows you how to configure the relay in macOS?
I already built the node from source, but not sure how to finish the setup. (topologyUpdater, gLiveView, Grafana)

Thank you

1 Like

Not working to install them following coincashew guide?

That guide works fine for Linux, but there is almost no documentation for running a stake pool on macOS, with the exception of a guide from some members of the Armada Alliance.

I was told with Mac Mini M1 there are three options:

  1. Use Armada Alliance guide for macOS with brew
    Apple M1 macOS 🍏 - 🇺🇸

  2. Use Armada Alliance with macOS and Docker image.
    Arm64 Docker Image and Stake Pool Guide - 🇺🇸

  3. Install Asahi Linux which I am told works well for stake pools, but still has missing components like Bluetooth…

I’ll weigh the pros and cons of macOS vs. Linux for ARM-based M1 before rebuilding the stake pool.

Thank you @Alexd1985

1 Like

Topology updater should work with minor changes I suppose. Bash scripts seems to work on Mac, generally speaking. Maybe you will need to have some little tweaks. If you have any problems, past errors here and I can try to help.

Grafana should be not a difference at all, as far as you get Grafana server running on same box or on separate server.

I think most challenging will be with gLiveView, it has a lot of scripts under the hood and I doubt it can be easily adjusted for Mac. I don’t use gLiveView at all, so take it with a grain of salt.

1 Like


I’m checking your URLs and seems that one is most interesting, at least for me:

Have you able to finish all steps what is described there?

Seems they even have solution for gLiveView

1 Like

Thank you @os11k, I appreciate your help.

It is very good to know which elements work and which need tweaking.

Tough choice, I will give it a thought overnight and decide how to do it, as I need to get out the cloud asap.

You’re right. I should give it a try.

I can try brew first and also the Docker image (recommended by member of Armada Alliance). He recommended Asahi over both methods, though. That is why I am not sure what to do.

Hi @parlange !

I personally would go with Docker, mainly because I’m huge Docker enthusiast and I think Docker will give a lot more advantages, like much easier to update and maintain. But if you have 0 knowledge about Docker it might get tough at the beginning.

In any case if you need any help with docker, please let me know.

Good luck!

The Docker tutorial seems amazing. You configure the image and then just communicate with it as a node container.

I have some basic Docker skills, never used it with Cardano.
I’ll try that method first, as you both SPOs recommend it if using macOS.

Thank you @os11k

1 Like

Hi :wave:, sorry for the weird inconvenience. my name is eddy and I’m trying to install a cardano node myself on Mac m1. I’ve tried following this installation process: Installing cardano-node and cardano-cli from source | Cardano Developer Portal

However it’s just not full proof. Too many snags and hiccups . I’m either denied access from my own Mac or command not found . Can you help me correct it or is there any other way you might know ?
Thank you :pray:


Do you have any details, what doesn’t work from that manual? I personally edited that manual for M1 and I checked it does work.

Please provide more details, so I can look into it.

1 Like

“Then we will add the following environment variables to your shell profile. E.G $HOME/.zshrc or `$HOME/.bashrc”

My shell is zshrc , and I do as it says I put $HOME/.zshrc and then the variables :

export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"

But it keeps saying permission denied, I tried a sudo command but then it says command not found . What am I doing wrong ?…


What happens when you try ls $HOME/.zshrc?

I assume no such file exists, if there are no such file you can create it.

1 Like

Hi :slightly_smiling_face:

Yep, you were right

ls: LD_LIBRARY_PATH=“/usr/local/lib:”: No such file or directory
ls: export: No such file or directory

I guess my question now is how can I create a file for it ?


I think you misunderstood, what command to run. It is:

ls $HOME/.zshrc

That command will try to list all files with that name.

Not sure why you tried to list something else based on your error below:

ls: LD_LIBRARY_PATH=“/usr/local/lib:”: No such file or directory
ls: export: No such file or directory

To create file, I would personally would use nano text editor, just google how to create or edit files in mac os

Not sure why you want to run cardano-node, but I would definitely recommend you to read a one or more books related to Linux/Unix or maybe even watch some video courses before moving on… Seems you have very little understanding about linux/unix and it will be much more harder down the road.

1 Like

Oh yeah of course I’m a complete noob :ok_hand::slightly_smiling_face:
However Cardano is the only blockchain I’d like to study and work with , from operating a stake pool to creating smart contracts, I like the idea of documenting the undocumented. Imagine having an ID like a driver license with the smart contract policy number as your ID number :smiley:

Anyways I see what you mean now I ran

ls $HOME/ .zshrc
And nothing comes up other than this : /Users/****/.zshrc
so I will take your advice and will see how to create a file.

And I will also study Unix/Linux more in depth👍

1 Like