Steps for 1.26.1 (non CNTOOLS , Coincashew users)

INFO!

It can take up to 1h until the DB is re-syncing. So it is normal that glive Status is on “starting”.

2 Likes

I like the copy db/ledger to the other nodes, especially that in most cases, there are 2 relays and 1 BP .

i didn’t upgrade ghc and cabal. is it recommended with 1.26.1 ?

No It’s not.

Hello guys, I updated to 1.26.1 and already sync all to relays and BP node.
I followed the coincashew guide.
But what I noticed in my Grafana dashboard is that Code Tx’s Processed is not received any more.
I also updated:

  • ghc to 8.10.4
  • cabal to 3.4.0.0

Is it a problem that I am still not receiving Code Tx’s Processed. And how to verify that my pool is running properly and can it produce blocks?

Here is a screenshots of my pool’s BP node and Grafana dashboard:

And my config :
{
“ApplicationName”: “cardano-sl”,
“ApplicationVersion”: 1,
“ByronGenesisFile”: “mainnet-byron-genesis.json”,
“ByronGenesisHash”: “5f20df933584822601f9e3f8c024eb5eb252fe8cefb24d1317dc3d432e940ebb”,
“LastKnownBlockVersion-Alt”: 0,
“LastKnownBlockVersion-Major”: 3,
“LastKnownBlockVersion-Minor”: 0,
“MaxKnownMajorProtocolVersion”: 2,
“Protocol”: “Cardano”,
“RequiresNetworkMagic”: “RequiresNoMagic”,
“ShelleyGenesisFile”: “mainnet-shelley-genesis.json”,
“ShelleyGenesisHash”: “1a3be38bcbb7911969283716ad7aa550250226b76a61fc51cc9a9a35d9276d81”,
“TraceBlockFetchClient”: false,
“TraceBlockFetchDecisions”: true,
“TraceBlockFetchProtocol”: false,
“TraceBlockFetchProtocolSerialised”: false,
“TraceBlockFetchServer”: false,
“TraceChainDb”: true,
“TraceChainSyncBlockServer”: false,
“TraceChainSyncClient”: false,
“TraceChainSyncHeaderServer”: false,
“TraceChainSyncProtocol”: false,
“TraceDNSResolver”: true,
“TraceDNSSubscription”: true,
“TraceErrorPolicy”: true,
“TraceForge”: true,
“TraceHandshake”: false,
“TraceIpSubscription”: true,
“TraceLocalChainSyncProtocol”: false,
“TraceLocalErrorPolicy”: true,
“TraceLocalHandshake”: false,
“TraceLocalTxSubmissionProtocol”: false,
“TraceLocalTxSubmissionServer”: false,
“TraceMempool”: true,
“TraceMux”: false,
“TraceTxInbound”: false,
“TraceTxOutbound”: false,
“TraceTxSubmissionProtocol”: false,
“TracingVerbosity”: “NormalVerbosity”,
“TurnOnLogMetrics”: true,
“TurnOnLogging”: true,
“defaultBackends”: [
“KatipBK”
],
“defaultScribes”: [
[
“StdoutSK”,
“stdout”
]
],
“hasEKG”: 12788,
“hasPrometheus”: [
“0.0.0.0”,
12798
],
“minSeverity”: “Info”,
“options”: {
“mapBackends”: {
“cardano.node.metrics”: [
“EKGViewBK”
],
“cardano.node.resources”: [
“EKGViewBK”
]
},
“mapSubtrace”: {
“cardano.node.metrics”: {
“subtrace”: “Neutral”
}
}
},
“rotation”: {
“rpKeepFilesNum”: 10,
“rpLogLimitBytes”: 5000000,
“rpMaxAgeHours”: 24
},
“setupBackends”: [
“KatipBK”
],
“setupScribes”: [
{
“scFormat”: “ScText”,
“scKind”: “StdoutSK”,
“scName”: “stdout”,
“scRotation”: null
}
]
}

Thanks for the great guide. For some reason, copying the compiled files to the right location doesn’t seem to work for me. I can see that both files in /usr/local/bin are updated. However, when I verify the version of the node it still returns 1.25.1.

Am I overlooking something? is there a method to check the location where the node is running from?

EDIT: I used command which cardano-cli to check the location of cardano-node and cardano-cli. Both ran from a different location. Fixed the issue by altering the cp command listed above.

2 Likes

How did you alter the command this is what I was trying to fix as well.

Had this exact same issue…

You need to change your PATH in .bashrc.

PATH works like PATH=first_look_here:then_look_here:and_so_on

If you punt the /usr/local/bin: in front it will look for the cardano-node in that location.

Change bash-file by sudo nano $HOME/.bashrc

Save with ctrl+o then ctrl+x

don’t forget to source ~/.bashrc and your good

1 Like

@Alexd1985 Can you look and tell at my problem, looks like you have pretty good understanding of Cardano pools at all :slight_smile:

hmm try to see if the node is exporting the metric

curl localhost:12798/metrics | grep TX

compare with the output from another node

1 Like

I am trying to update my pool.cert after i changed my public IP to a DNS record, but i am not able to complete the steps with 1.26.1 .
This command is failing with error saying when decoding the params.json , key “DECENTRALIZATION” not found.

(note that after i upgraded to 1.26.1 - all my nodes were online and connected as expected)

fee=(cardano-cli transaction calculate-min-fee \ --tx-body-file tx.tmp \ --tx-in-count {txcnt}
–tx-out-count 1
–mainnet
–witness-count 3
–byron-witness-count 0
–protocol-params-file params.json | awk ‘{ print $1 }’)
echo fee: $fee

Yeap, you are right. BP node don’t export cardano_node_metrics_txsProcessedNum_int. Any advice how to fix that?

Howbis the config file?

Did u set to true traceMempool?

I shared all info, little bit up in this topic… Steps for 1.26.1 (non CNTOOLS , Coincashew users) - #47 by toome123

traceMempool is set to true

1 Like

Ok,

Try to compare the config file from producer with one of your relay… I think something is different

There is no difference… But the files are old from 1.25.1. It is necessary to fetch new files for this build ?

I don’t think so… did u tried to restart the node?

Yes, many times, also prometheus.service. but nothing…
First i rebuild 1.26.1 by my self with old versions of ghc and cabal. And everything works fine, after that i saw coincashew guide and their suggest to update ghc to 8.10.4 and cabal to 3.4.0.0. and did it again. And then i noticed this problem… i dont know if this info is helpful but…

Check for ur all nodes

ghc - -version
cabal - -version

Are same for all nodes?

1 Like

All are the same.