Testnet 1.24.2 sync problem


I am creating a relay node following


While syncing data, I keep getting this error


Is this intended?

A couple of times the chain is extended

[ip-172-3:cardano.node.ChainDB:Notice:38] [2021-01-19 13:58:54.61 UTC] Chain extended, new tip: 387dba492acfd1e5a0e209f5339341b901315cd209f9f591780f4820f3c8bb9b at slot 14913741`

Most of the time it shows this error

[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.51 UTC] epoch = 104
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.51 UTC] density = 3.402688155119771e-2
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.51 UTC] slotNum = 14913618
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.51 UTC] blockNum = 2183879
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.51 UTC] slotInEpoch = 355218
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.51 UTC] epoch = 104
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] density = 3.4037798794592976e-2
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] slotNum = 14913627
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] blockNum = 2183880
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] slotInEpoch = 355227
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] epoch = 104
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] density = 3.4025157232704405e-2
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] slotNum = 14913680
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] blockNum = 2183881
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] slotInEpoch = 355280
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.52 UTC] epoch = 104
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.54 UTC] density = 3.403766940225765e-2
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.54 UTC] slotNum = 14913686
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.54 UTC] blockNum = 2183882
[ip-172-3:cardano.node.ChainDB.metrics:Critical:38] [2021-01-19 13:58:54.54 UTC] slotInEpoch = 355286

I am using this command to run the relay

cardano-node run
–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–port 3001
–config testnet-config.json

When I run

cardano-cli shelley query tip --testnet-magic 1097911063

I get

“blockNo”: 1928997,
“headerHash”: “93bdc1911c29123dc62cadf6562e145e7c0bfb4bb983913886904bc2e9195a5b”,
“slotNo”: 8416514

Same problem here.

I don’t think it is an error. You will get that until your node is fully synced. Meanwhile, your node will occasionally receive freshly minted blocks, that you see as well under the newly extended flag.

Ok, got the explanation from Telegram.
Likely because you are using a node config file that is meant for the next version of the node 1.25.0. This has been pushed on the hydra/latest configs files.
No worries, it still works.

1 Like

Please check out this solution for the testnet:



Thanks for the replies!

Just an update here:

1st - Thx you all for the help. It’s my first time running a relay node in testnet and I was having the same issue because the config file was downloaded from the repo (latest) but the version of cardano-node was 1.24.x as I was following the course documentation: Installing Cardano-node - Stake pool course

I updated the cardano-node to the latest (1.25.x) and it worked (“chain extended…”)

i am following the stake pool course, where is still stated to checkout at 1.24.1 , is this correct?

luwkaslima was correct. I had this issue today and got tag 1.25.1 compiled.

I have been following the testnet setup guide (for AWS) and I was seeing a similar issue where the node was not syncing and I did 3 things to solve my issue:
Update cardano node to the latest (1.25.1 as of now) (Thanks @luwkaslima)
cd ~/cardano-node/
git checkout tags/1.25.1
Update the testnet-config.json
Following the setup instructions we use wget to download https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/testnet-config.json but I replaced that download with the contents from
IP address for cardano-node run set to --host-addr
cardano-node run
–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–port 3001
–config testnet-config.json